CVE-2026-33007 Apache HTTP Server: mod_authn_socache crash
An unauthenticated remote attacker can crash a child process in Apache HTTP Server when configured as a caching forward proxy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33007?
CVE-2026-33007 is a medium-severity vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A NULL pointer dereference in the mod_authn_socache in Apache HTTP Server 2.4.66 and earlier allows an unauthenticated remote user to crash a child process in a caching forward proxy configuration.
Users are recommended to upgrade to version 2.4.67, which fixes this issue.
Weakness: CWE-476
Which versions are affected by CVE-2026-33007?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.67 |
Products include Apache Http Server.
How do I fix CVE-2026-33007?
Upgrade apache to 2.4.67 or later.
Is CVE-2026-33007 being exploited?
There is no known exploitation of CVE-2026-33007 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-33007, AZL-86016, BELL-CVE-2026-33007, BIT-apache-2026-33007, DEBIAN-CVE-2026-33007, GHSA-cj6w-grf6-jq78 and 2 more.