CVE-2026-33026 nginx-ui Backup Restore Allows Tampering with Encrypted Backups

Critical 9.4 Published Updated

Attackers can tamper with encrypted backups to inject malicious configurations during restoration in Nginx UI, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33026?

CVE-2026-33026 is a critical vulnerability in 0xJacky nginx-ui, published on 30 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui backup restore mechanism allows attackers to tamper with encrypted backup archives and inject malicious configuration during restoration. This issue has been patched in version 2.3.4.

Weakness: CWE-354, CWE-347, CWE-312

Which versions are affected by CVE-2026-33026?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI. It affects 1 product.

PackageAffectedFixed in
github.com/0xJacky/Nginx-UI GoAll versionsNone
github.com/0xJacky/Nginx-UI GoAll versions1.9.10-0.20260315015203-f61bcec547c0
github.com/0xJacky/Nginx-UI GoAll versions1.9.10-0.20260315015203-f61bcec547c0

Products include Nginxui Nginx Ui.

How do I fix CVE-2026-33026?

Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260315015203-f61bcec547c0 or later.

Is CVE-2026-33026 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33026 exists.

Sources

Also known as GHSA-fhh2-gg7w-gwpq, GO-2026-4903.

Is CVE-2026-33026 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free