# CVE-2026-33026: nginx-ui Backup Restore Allows Tampering with Encrypted Backups

> Attackers can tamper with encrypted backups to inject malicious configurations during restoration in Nginx UI, potentially leading to code execution.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** GHSA-fhh2-gg7w-gwpq, GO-2026-4903

## What is CVE-2026-33026?

CVE-2026-33026 is a critical vulnerability in 0xJacky nginx-ui, published on 30 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui backup restore mechanism allows attackers to tamper with encrypted backup archives and inject malicious configuration during restoration. This issue has been patched in version 2.3.4.

Weakness: CWE-354 (Improper Validation of Integrity Check Value), CWE-347 (Improper Verification of Cryptographic Signature), CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2026-33026?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | None |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260315015203-f61bcec547c0 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260315015203-f61bcec547c0 |

Products: Nginxui Nginx Ui.

## How do I fix CVE-2026-33026?

Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260315015203-f61bcec547c0 or later.

## Is CVE-2026-33026 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33026 exists.

## Other vulnerabilities in 0xJacky nginx-ui

- [CVE-2026-33032](https://insights.sbomify.com/CVE-2026-33032/): Nginx UI: Unauthenticated MCP Endpoint Allows Remote Nginx Takeover (critical 9.8)
- [CVE-2026-27944](https://insights.sbomify.com/CVE-2026-27944/): Nginx UI: Unauthenticated Backup Download with Encryption Key Disclosure (critical 9.8)
- [CVE-2024-23827](https://insights.sbomify.com/CVE-2024-23827/): Nginx-UI arbitrary file write through the Import Certificate feature (critical 9.8)
- [CVE-2026-107806](https://insights.sbomify.com/CVE-2026-107806/): Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite (critical 9.4)
- [CVE-2026-42238](https://insights.sbomify.com/CVE-2026-42238/): Unauthenticated Remote Code Execution via Backup Restore in nginx-ui (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33026 and fix it if it is affected.

What it is: CVE-2026-33026 is a critical vulnerability in 0xJacky nginx-ui, published on 30 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33026 exists.

Affected packages and fixed versions:
- github.com/0xJacky/Nginx-UI (Go): affected all versions; no fix listed
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260315015203-f61bcec547c0
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260315015203-f61bcec547c0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33026/ (Markdown: https://insights.sbomify.com/CVE-2026-33026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33026
- OSV: https://osv.dev/vulnerability/CVE-2026-33026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33026/
Summaries are generated and may contain mistakes; the official description above is the record.
