# CVE-2026-33029: Nginx UI: DoS via Negative Integer Input in Logrotate Interval

> An authenticated user can cause a complete Denial of Service in Nginx UI by submitting a negative integer for the logrotate interval.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2026
- **Updated:** 1 Apr 2026
- **Also known as:** GHSA-cp8r-8jvw-v3qg, GO-2026-4902

## What is CVE-2026-33029?

CVE-2026-33029 is a medium-severity denial of service vulnerability in 0xJacky nginx-ui, published on 30 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, an input validation vulnerability in the logrotate configuration allows an authenticated user to cause a complete Denial of Service (DoS). By submitting a negative integer for the rotation interval, the backend enters an infinite loop or an invalid state, rendering the web interface unresponsive. This issue has been patched in version 2.3.4.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-33029?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | None |
| `github.com/0xJacky/Nginx-UI` | Go | All versions to 1.99 | None |
| `github.com/0xJacky/Nginx-UI` | Go | All versions to 1.99 | None |

Products: Nginxui Nginx Ui.

## How do I fix CVE-2026-33029?

Upgrade to a fixed version.

## Is CVE-2026-33029 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33029 exists.

## Other vulnerabilities in 0xJacky nginx-ui

- [CVE-2026-33032](https://insights.sbomify.com/CVE-2026-33032/): Nginx UI: Unauthenticated MCP Endpoint Allows Remote Nginx Takeover (critical 9.8)
- [CVE-2026-27944](https://insights.sbomify.com/CVE-2026-27944/): Nginx UI: Unauthenticated Backup Download with Encryption Key Disclosure (critical 9.8)
- [CVE-2024-23827](https://insights.sbomify.com/CVE-2024-23827/): Nginx-UI arbitrary file write through the Import Certificate feature (critical 9.8)
- [CVE-2026-107806](https://insights.sbomify.com/CVE-2026-107806/): Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite (critical 9.4)
- [CVE-2026-33026](https://insights.sbomify.com/CVE-2026-33026/): nginx-ui Backup Restore Allows Tampering with Encrypted Backups (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33029 and fix it if it is affected.

What it is: CVE-2026-33029 is a medium-severity denial of service vulnerability in 0xJacky nginx-ui, published on 30 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33029 exists.

Affected packages and fixed versions:
- github.com/0xJacky/Nginx-UI (Go): affected all versions; no fix listed
- github.com/0xJacky/Nginx-UI (Go): affected all versions up to 1.99; no fix listed
- github.com/0xJacky/Nginx-UI (Go): affected all versions up to 1.99; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33029/ (Markdown: https://insights.sbomify.com/CVE-2026-33029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33029
- OSV: https://osv.dev/vulnerability/CVE-2026-33029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33029/
Summaries are generated and may contain mistakes; the official description above is the record.
