# CVE-2026-33033: Potential denial-of-service vulnerability in MultiPartParser via base64-encoded file upload

> Remote attackers can degrade Django server performance by submitting multipart uploads with excessive base64 whitespace, requiring an upgrade to patched versions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** BIT-django-2026-33033, CLSA-2026-1787042978, DEBIAN-CVE-2026-33033, ECHO-3bfd-1865-8be2, GHSA-5mf9-h53q-7mhq, MINI-4wvq-5qwr-wp23, PYSEC-2026-48, UBUNTU-CVE-2026-33033

## What is CVE-2026-33033?

CVE-2026-33033 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in 6.0 before 6.0.4, 5.2 before 5.2.13, and 4.2 before 4.2.30.
`MultiPartParser` allows remote attackers to degrade performance by submitting multipart uploads with `Content-Transfer-Encoding: base64` including excessive whitespace.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Seokchan Yoon for reporting this issue.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-33033?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.30, 5.2.13, 6.0.4 |
| `django` | PyPI | From 4.2 | 4.2.30, 5.2.13, 6.0.4 |
| `django` | PyPI | From 4.2 | 4.2.30 |
| `django` | PyPI | From 5.2 | 5.2.13 |
| `django` | PyPI | From 6.0 | 6.0.4 |
| `Django` | PyPI | From 4.2 | 4.2.30 |
| `Django` | PyPI | From 5.2 | 5.2.13 |
| `Django` | PyPI | From 6.0 | 6.0.4 |

Products: Djangoproject Django.

## How do I fix CVE-2026-33033?

Upgrade django to a fixed version for your release line: 4.2.30, 5.2.13 or 6.0.4.

## Is CVE-2026-33033 being exploited?

There is no known exploitation of CVE-2026-33033 in the wild and no public exploit code.

Public exploit code:

- A PoC script for demonstrating CVE-2026-33033 (github_poc): https://github.com/ch4n3-yoon/CVE-2026-33033-PoC

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33033 and fix it if it is affected.

What it is: CVE-2026-33033 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33033 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.30, 5.2.13, 6.0.4
- django (PyPI): affected from 4.2; fixed in 4.2.30, 5.2.13, 6.0.4
- django (PyPI): affected from 4.2; fixed in 4.2.30
- django (PyPI): affected from 5.2; fixed in 5.2.13
- django (PyPI): affected from 6.0; fixed in 6.0.4
- Django (PyPI): affected from 4.2; fixed in 4.2.30
- Django (PyPI): affected from 5.2; fixed in 5.2.13
- Django (PyPI): affected from 6.0; fixed in 6.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33033/ (Markdown: https://insights.sbomify.com/CVE-2026-33033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33033
- OSV: https://osv.dev/vulnerability/CVE-2026-33033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33033/
Summaries are generated and may contain mistakes; the official description above is the record.
