# CVE-2026-33035: Unauthenticated Reflected XSS via innerHTML in AVideo

> Unauthenticated attackers can execute arbitrary JavaScript via reflected XSS in AVideo, leading to session theft and account takeover.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-wfq5-qgqp-hvhv

## What is CVE-2026-33035?

CVE-2026-33035 is a medium-severity cross-site scripting vulnerability in Wwbn Avideo, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

WWBN AVideo is an open source video platform. In versions 25.0 and below, there is a reflected XSS vulnerability that allows unauthenticated attackers to execute arbitrary JavaScript in a victim's browser. User input from a URL parameter flows through PHP's json_encode() into a JavaScript function that renders it via innerHTML, bypassing encoding and achieving full script execution. The vulnerability is caused by two issues working together: unescaped user input passed to JavaScript (videoNotFound.php), and innerHTML rendering HTML tags as executable DOM (script.js).  The attack can be escalated to steal session cookies, take over accounts, phish credentials via injected login forms, spread self-propagating payloads, and compromise admin accounts — all by exploiting the lack of proper input sanitization and cookie security (e.g., missing HttpOnly flag on PHPSESSID). The issue has been fixed in version 26.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-33035?

2 open source packages ship an affected version, including wwbn/avideo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wwbn/avideo` | Packagist | All versions to 25.0 | None |
| `wwbn/avideo` | Packagist | All versions to 25.0 | None |

Products: Wwbn Avideo.

## How do I fix CVE-2026-33035?

No fix has been published for CVE-2026-33035 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33035 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33035 exists.

## Other vulnerabilities in Wwbn Avideo

- [CVE-2026-40911](https://insights.sbomify.com/CVE-2026-40911/): WWBN AVideo YPTSocket WebSocket Broadcast Relay Leads to Unauthenticated Cross-User JavaScript Execution via Client-Side eval() Sinks (critical 10.0)
- [CVE-2026-33478](https://insights.sbomify.com/CVE-2026-33478/): AVideo Multi-Chain Attack: Unauthenticated Remote Code Execution via Clone Key Disclosure, Database Dump, and Command Injection (critical 10.0)
- [CVE-2022-30534](https://insights.sbomify.com/CVE-2022-30534/): Command injection in AVideo (critical 9.9)
- [CVE-2022-30547](https://insights.sbomify.com/CVE-2022-30547/): Path traversal in AVideo (critical 9.9)
- [CVE-2022-32572](https://insights.sbomify.com/CVE-2022-32572/): Command injection in AVideo (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33035 and fix it if it is affected.

What it is: CVE-2026-33035 is a medium-severity cross-site scripting vulnerability in Wwbn Avideo, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33035 exists.

Affected packages and fixed versions:
- wwbn/avideo (Packagist): affected all versions up to 25.0; no fix listed
- wwbn/avideo (Packagist): affected all versions up to 25.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33035/ (Markdown: https://insights.sbomify.com/CVE-2026-33035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33035
- OSV: https://osv.dev/vulnerability/CVE-2026-33035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33035/
Summaries are generated and may contain mistakes; the official description above is the record.
