CVE-2026-33036 fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)
An attacker can cause denial of service in fast-xml-parser by using numeric entity references that bypass expansion limits, leading to excessive memory and CPU usage.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33036?
CVE-2026-33036 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
fast-xml-parser allows users to process XML from JS object without C/C++ based libraries or callbacks. Versions 4.0.0-beta.3 through 5.5.5 contain a bypass vulnerability where numeric character references (&#NNN;, &#xHH;) and standard XML entities completely evade the entity expansion limits (e.g., maxTotalExpansions, maxExpandedLength) added to fix CVE-2026-26278, enabling XML entity expansion Denial of Service. The root cause is that replaceEntitiesValue() in OrderedObjParser.js only enforces expansion counting on DOCTYPE-defined entities while the lastEntities loop handling numeric/standard entities performs no counting at all. An attacker supplying 1M numeric entity references like A can force ~147MB of memory allocation and heavy CPU usage, potentially crashing the process—even when developers have configured strict limits. This issue has been fixed in version 5.5.6.
Weakness: CWE-776
Which versions are affected by CVE-2026-33036?
4 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fast-xml-parser npm | From 4.0.0-beta.3 | 4.5.5 |
fast-xml-parser npm | From 4.0.0-beta.3 | 4.5.5 |
fast-xml-parser npm | From 5.0.0 | 5.5.6 |
fast-xml-parser npm | From 5.0.0 | 5.5.6 |
Linux distribution packages (1)
heroic-games-launcher openSUSE:Tumbleweed | All versions | 2.20.1-4.1 |
Products include Naturalintelligence Fast-Xml-Parser.
How do I fix CVE-2026-33036?
Upgrade fast-xml-parser to a fixed version for your release line: 4.5.5 or 5.5.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-33036 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33036 exists.
Other vulnerabilities in NaturalIntelligence fast-xml-parser
- CVE-2026-25896 fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names
- CVE-2026-26278 fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit)
- CVE-2026-25128 fast-xml-parser has RangeError DoS Numeric Entities Bug
- CVE-2024-41818 ReDOS at currency parsing fast-xml-parser
- CVE-2023-34104 Regex Injection via Doctype Entities
Sources
Also known as CLEANSTART-2026-DN87303, CLEANSTART-2026-HQ50857, CLSA-2026-1790005086, DEBIAN-CVE-2026-33036, ECHO-d6a2-ff98-f3bf, GHSA-8gc5-j5rx-235r and 19 more.