# CVE-2026-33036: fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)

> An attacker can cause denial of service in fast-xml-parser by using numeric entity references that bypass expansion limits, leading to excessive memory and CPU usage.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** CLEANSTART-2026-DN87303, CLEANSTART-2026-HQ50857, CLSA-2026-1790005086, DEBIAN-CVE-2026-33036, ECHO-d6a2-ff98-f3bf, GHSA-8gc5-j5rx-235r, MINI-23hw-qf3p-v2c9, MINI-2fcp-347x-h28q, MINI-447h-x75q-3vwf, MINI-565x-vhhm-459h, MINI-5f5w-qjcv-8452, MINI-648p-h398-4cp8, MINI-64qx-p4fv-47v7, MINI-94j4-mrqj-7x7h, MINI-f3f8-q457-g4rr, MINI-m2rq-8h9r-p47g, MINI-mfmv-rv83-4h42, MINI-mvxc-w3rv-685m, MINI-p7wc-9hpp-4jmm, MINI-r5rw-x3mc-hwp2, MINI-rxqm-ffj3-fgrj, MINI-vxmp-rmx3-6jfg, ROOT-APP-NPM-CVE-2026-33036, UBUNTU-CVE-2026-33036, openSUSE-SU-2026:10462-1

## What is CVE-2026-33036?

CVE-2026-33036 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-xml-parser allows users to process XML from JS object without C/C++ based libraries or callbacks. Versions 4.0.0-beta.3 through 5.5.5 contain a bypass vulnerability where numeric character references (&#NNN;, &#xHH;) and standard XML entities completely evade the entity expansion limits (e.g., maxTotalExpansions, maxExpandedLength) added to fix CVE-2026-26278, enabling XML entity expansion Denial of Service. The root cause is that replaceEntitiesValue() in OrderedObjParser.js only enforces expansion counting on DOCTYPE-defined entities while the lastEntities loop handling numeric/standard entities performs no counting at all. An attacker supplying 1M numeric entity references like &#65; can force ~147MB of memory allocation and heavy CPU usage, potentially crashing the process—even when developers have configured strict limits. This issue has been fixed in version 5.5.6.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2026-33036?

4 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-parser` | npm | From 4.0.0-beta.3 | 4.5.5 |
| `fast-xml-parser` | npm | From 4.0.0-beta.3 | 4.5.5 |
| `fast-xml-parser` | npm | From 5.0.0 | 5.5.6 |
| `fast-xml-parser` | npm | From 5.0.0 | 5.5.6 |
| `heroic-games-launcher` | openSUSE:Tumbleweed | All versions | 2.20.1-4.1 |

Products: Naturalintelligence Fast-Xml-Parser.

## How do I fix CVE-2026-33036?

Upgrade fast-xml-parser to a fixed version for your release line: 4.5.5 or 5.5.6.

## Is CVE-2026-33036 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33036 exists.

## Other vulnerabilities in NaturalIntelligence fast-xml-parser

- [CVE-2026-25896](https://insights.sbomify.com/CVE-2026-25896/): fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names (critical 9.3)
- [CVE-2026-26278](https://insights.sbomify.com/CVE-2026-26278/): fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit) (high 7.5)
- [CVE-2026-25128](https://insights.sbomify.com/CVE-2026-25128/): fast-xml-parser has RangeError DoS Numeric Entities Bug (high 7.5)
- [CVE-2024-41818](https://insights.sbomify.com/CVE-2024-41818/): ReDOS at currency parsing fast-xml-parser (high 7.5)
- [CVE-2023-34104](https://insights.sbomify.com/CVE-2023-34104/): Regex Injection via Doctype Entities (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33036 and fix it if it is affected.

What it is: CVE-2026-33036 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33036 exists.

Affected packages and fixed versions:
- fast-xml-parser (npm): affected from 4.0.0-beta.3; fixed in 4.5.5
- fast-xml-parser (npm): affected from 4.0.0-beta.3; fixed in 4.5.5
- fast-xml-parser (npm): affected from 5.0.0; fixed in 5.5.6
- fast-xml-parser (npm): affected from 5.0.0; fixed in 5.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33036/ (Markdown: https://insights.sbomify.com/CVE-2026-33036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33036
- OSV: https://osv.dev/vulnerability/CVE-2026-33036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33036/
Summaries are generated and may contain mistakes; the official description above is the record.
