# CVE-2026-33046: Indico discloses local files resulting in Remote Code Execution through LaTeX injection

> Attackers can execute arbitrary code and read local files via LaTeX injection in Indico if server-side rendering is enabled.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-rm2q-f7jv-3cfp, PYSEC-2026-2184

## What is CVE-2026-33046?

CVE-2026-33046 is a high-severity code injection vulnerability in indico, published on 23 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. In versions prior to 3.3.12, due to vulnerabilities in TeXLive and obscure LaTeX syntax that allowed circumventing Indico's LaTeX sanitizer, it is possible to use specially-crafted LaTeX snippets which can read local files or execute code with the privileges of the user running Indico on the server. Note that if server-side LaTeX rendering is not in use (ie `XELATEX_PATH` was not set in `indico.conf`), this vulnerability does not apply. It is recommended to update to Indico 3.3.12 as soon as possible. It is also strongly recommended to enable the containerized LaTeX renderer (using `podman`), which isolates it from the rest of the system. As a workaround, remove the `XELATEX_PATH` setting from `indico.conf` (or comment it out or set it to `None`) and restart the `indico-uwsgi` and `indico-celery` services to disable LaTeX functionality.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-33046?

3 open source packages ship an affected version, including indico. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 3.3.12 |
| `indico` | PyPI | All versions | 3.3.12 |
| `indico` | PyPI | All versions | 3.3.12 |

Products: Cern Indico.

## How do I fix CVE-2026-33046?

Upgrade indico to 3.3.12 or later.

## Is CVE-2026-33046 being exploited?

There is no known exploitation of CVE-2026-33046 in the wild and no public exploit code.

## Other vulnerabilities in indico

- [CVE-2021-30185](https://insights.sbomify.com/CVE-2021-30185/): Indico Tampering with links (e.g. password reset) in sent emails (high 7.5)
- [CVE-2026-25738](https://insights.sbomify.com/CVE-2026-25738/): Indico has Server-Side Request Forgery (SSRF) in multiple places (medium 6.9)
- [CVE-2026-28352](https://insights.sbomify.com/CVE-2026-28352/): Indico missing access check in event series management API (medium 6.5)
- [CVE-2026-25739](https://insights.sbomify.com/CVE-2026-25739/): Indico affected by Cross-Site-Scripting via material uploads (medium 5.4)
- [CVE-2023-37901](https://insights.sbomify.com/CVE-2023-37901/): Cross-Site-Scripting via confirmation prompts (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33046 and fix it if it is affected.

What it is: CVE-2026-33046 is a high-severity code injection vulnerability in indico, published on 23 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33046 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 3.3.12
- indico (PyPI): affected all versions; fixed in 3.3.12
- indico (PyPI): affected all versions; fixed in 3.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33046/ (Markdown: https://insights.sbomify.com/CVE-2026-33046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33046
- OSV: https://osv.dev/vulnerability/CVE-2026-33046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33046/
Summaries are generated and may contain mistakes; the official description above is the record.
