# CVE-2026-33052: MantisBT: Authorization Bypass in Global Profile Creation

> Low-privileged users can create global profiles by tampering with user_id, bypassing authorization checks in MantisBT.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 19 May 2026
- **Also known as:** GHSA-68w5-w573-q2r8

## What is CVE-2026-33052?

CVE-2026-33052 is a medium-severity missing authorization vulnerability in mantisbt, published on 19 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.28.0 and 2.28.1 allow a low-privileged authenticated user assigned the "add_profile_threshold" permission to create a global profile despite not having manage_global_profile_threshold, by tampering with the user_id parameter in a valid profile creation request. This issue has been fixed in version 2.28.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-33052?

2 open source packages ship an affected version, including mantisbt/mantisbt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | From 2.28.0 | 2.28.2 |
| `mantisbt/mantisbt` | Packagist | From 2.28.0 | 2.28.2 |

## How do I fix CVE-2026-33052?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

## Is CVE-2026-33052 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33052 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33052 and fix it if it is affected.

What it is: CVE-2026-33052 is a medium-severity missing authorization vulnerability in mantisbt, published on 19 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33052 exists.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected from 2.28.0; fixed in 2.28.2
- mantisbt/mantisbt (Packagist): affected from 2.28.0; fixed in 2.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33052/ (Markdown: https://insights.sbomify.com/CVE-2026-33052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33052
- OSV: https://osv.dev/vulnerability/CVE-2026-33052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33052/
Summaries are generated and may contain mistakes; the official description above is the record.
