CVE-2026-33055 tar-rs incorrectly ignores PAX size headers if header size is nonzero

Medium 5.1 Published Updated

Attackers can craft tar archives that appear differently to tar-rs than other parsers, potentially bypassing security checks or causing logic errors.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-33055?

CVE-2026-33055 is a medium-severity vulnerability in alexcrichton tar-rs, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

tar-rs is a tar archive reading/writing library for Rust. Versions 0.4.44 and below have conditional logic that skips the PAX size header in cases where the base header size is nonzero. As part of CVE-2025-62518, the astral-tokio-tar project was changed to correctly honor PAX size headers in the case where it was different from the base header. This is almost the inverse of the astral-tokio-tar issue. Any discrepancy in how tar parsers honor file size can be used to create archives that appear differently when unpacked by different archivers. In this case, the tar-rs (Rust tar) crate is an outlier in checking for the header size - other tar parsers (including e.g. Go archive/tar) unconditionally use the PAX size override. This can affect anything that uses the tar crate to parse archives and expects to have a consistent view with other parsers. This issue has been fixed in version 0.4.45.

Weakness: CWE-843

Which versions are affected by CVE-2026-33055?

3 open source packages ship an affected version, including tar. It affects 1 product.

PackageAffectedFixed in
tar crates.ioAll versions0.4.45
tar crates.ioAll versions0.4.45
tar crates.ioFrom 0.0.0-00.4.45

Products include Alexcrichton Tar-Rs.

How do I fix CVE-2026-33055?

Upgrade tar to 0.4.45 or later.

Is CVE-2026-33055 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33055 exists.

Sources

Also known as AZL-80318, AZL-80496, AZL-80505, AZL-80508, AZL-80520, AZL-83034 and 10 more.

Is CVE-2026-33055 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free