# CVE-2026-33057: Mesop Affected by Unauthenticated Remote Code Execution via Test Suite Route /exec-py

> Unauthenticated attackers can execute arbitrary Python code via the /exec-py endpoint in Mesop, leading to full host compromise.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** GHSA-gjgx-rvqr-6w6v, PYSEC-2026-412

## What is CVE-2026-33057?

CVE-2026-33057 is a critical code injection vulnerability in mesop-dev mesop, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mesop is a Python-based UI framework that allows users to build web applications. In versions 1.2.2 and below, an explicit web endpoint inside the ai/ testing module infrastructure directly ingests untrusted Python code strings unconditionally without authentication measures, yielding standard Unrestricted Remote Code Execution. Any individual capable of routing HTTP logic to this server block will gain explicit host-machine command rights. The AI codebase package includes a lightweight debugging Flask server inside ai/sandbox/wsgi_app.py. The /exec-py route accepts base_64 encoded raw string payloads inside the code parameter natively evaluated by a basic POST web request. It saves it rapidly to the operating system logic path and injects it recursively using execute_module(module_path...). This issue has been fixed in version 1.2.3.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-33057?

3 open source packages ship an affected version, including mesop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mesop` | PyPI | All versions | 1.2.3 |
| `mesop` | PyPI | All versions | 1.2.3 |
| `mesop` | PyPI | All versions | 1.2.3 |

Products: Mesop-Dev Mesop.

## How do I fix CVE-2026-33057?

Upgrade mesop to 1.2.3 or later.

## Is CVE-2026-33057 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33057 exists.

Public exploit code:

- CVE-2026-33057 - Mesop Unauthenticated RCE PoC and yara rules  (github_poc): https://github.com/hackpatato/CVE-2026-33057---Mesop-Unauthenticated-RCE-PoC-and-yara-rules
- Mesop AI Sandbox <= 1.2.2 - Remote Code Execution (nuclei): http/cves/2026/CVE-2026-33057.yaml

## Other vulnerabilities in mesop-dev mesop

- [CVE-2026-33054](https://insights.sbomify.com/CVE-2026-33054/): Mesop has a Path Traversal utilizing `FileStateSessionBackend` leads to Application Denial of Service and File Write/Deletion (critical 10.0)
- [CVE-2026-34824](https://insights.sbomify.com/CVE-2026-34824/): Mesop: Unbounded Thread Creation in WebSocket Handler Leads to Denial of Service (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33057 and fix it if it is affected.

What it is: CVE-2026-33057 is a critical code injection vulnerability in mesop-dev mesop, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33057 exists.

Affected packages and fixed versions:
- mesop (PyPI): affected all versions; fixed in 1.2.3
- mesop (PyPI): affected all versions; fixed in 1.2.3
- mesop (PyPI): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33057/ (Markdown: https://insights.sbomify.com/CVE-2026-33057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33057
- OSV: https://osv.dev/vulnerability/CVE-2026-33057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33057/
Summaries are generated and may contain mistakes; the official description above is the record.
