# CVE-2026-33062: free5GC NRF Discovery EncodeGroupId Function Panics on Malformed group-id-list Parameter

> Remote attackers can crash the free5GC NRF discovery service by sending malformed HTTP requests, causing a denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 21 Mar 2026
- **Also known as:** GHSA-7c47-xr7q-p6hg, GO-2026-4756

## What is CVE-2026-33062?

CVE-2026-33062 is a high-severity denial of service vulnerability in Free5gc Free5gc, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

free5GC is an open source 5G core network. free5GC NRF prior to version 1.4.2 has an Improper Input Validation vulnerability leading to Denial of Service. All deployments of free5GC using the NRF discovery service are affected. The `EncodeGroupId` function attempts to access array indices [0], [1], [2] without validating the length of the split data. When the parameter contains insufficient separator characters, the code panics with "index out of range". A remote attacker can cause the NRF service to panic and crash by sending a crafted HTTP GET request with a malformed `group-id-list` parameter. This results in complete denial of service for the NRF discovery service. free5GC NRF version 1.4.2 fixes the issue. There is no direct workaround at the application level. The recommendation is to apply the provided patch or restrict access to the NRF API to trusted sources only.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-33062?

3 open source packages ship an affected version, including github.com/free5gc/nrf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/nrf` | Go | All versions | 1.4.2 |
| `github.com/free5gc/nrf` | Go | All versions | 1.4.2 |
| `github.com/free5gc/nrf` | Go | All versions | 1.4.2 |

Products: Free5gc Free5gc.

## How do I fix CVE-2026-33062?

Upgrade github.com/free5gc/nrf to 1.4.2 or later.

## Is CVE-2026-33062 being exploited?

There is no known exploitation of CVE-2026-33062 in the wild and no public exploit code.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44315](https://insights.sbomify.com/CVE-2026-44315/): free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33062 and fix it if it is affected.

What it is: CVE-2026-33062 is a high-severity denial of service vulnerability in Free5gc Free5gc, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33062 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/free5gc/nrf (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/nrf (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/nrf (Go): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33062/ (Markdown: https://insights.sbomify.com/CVE-2026-33062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33062
- OSV: https://osv.dev/vulnerability/CVE-2026-33062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33062/
Summaries are generated and may contain mistakes; the official description above is the record.
