# CVE-2026-33063: free5GC AUSF UE Authentication Panic on Nil SuciSupiMap Interface Conversion

> Remote attackers can crash the free5GC AUSF authentication service by sending crafted requests that trigger a nil interface conversion panic.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-4jrw-92fg-4jwx, GO-2026-4754

## What is CVE-2026-33063?

CVE-2026-33063 is a high-severity vulnerability in Free5gc Free5gc, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

free5GC is an open source 5G core network. free5GC AUSF prior to version 1.4.2 has is an Improper Null Check vulnerability leading to Denial of Service. All deployments of free5GC v4.0.1 using the AUSF UE authentication service (`/nausf-auth/v1/ue-authentications` endpoint) are affected. A remote attacker can cause the AUSF service to panic and crash by sending a crafted UE authentication request that triggers a nil interface conversion in the `GetSupiFromSuciSupiMap` function. This results in complete denial of service for the AUSF authentication service. The `GetSupiFromSuciSupiMap` function attempts to perform an interface conversion from `interface{}` to `*context.SuciSupiMap` without checking if the underlying value is nil. When `SuciSupiMap` is nil, the code panics with "interface conversion: interface {} is nil, not *context.SuciSupiMap". free5GC AUSF version 1.4.2 patches the issue.  There is no direct workaround at the application level. The recommendation is to apply the provided patch or restrict access to the AUSF API to trusted sources only.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-33063?

3 open source packages ship an affected version, including github.com/free5gc/ausf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/ausf` | Go | All versions | 1.4.2 |
| `github.com/free5gc/ausf` | Go | All versions | 1.4.2 |
| `github.com/free5gc/ausf` | Go | All versions | 1.4.2 |

Products: Free5gc Free5gc.

## How do I fix CVE-2026-33063?

Upgrade github.com/free5gc/ausf to 1.4.2 or later.

## Is CVE-2026-33063 being exploited?

There is no known exploitation of CVE-2026-33063 in the wild and no public exploit code.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44315](https://insights.sbomify.com/CVE-2026-44315/): free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33063 and fix it if it is affected.

What it is: CVE-2026-33063 is a high-severity vulnerability in Free5gc Free5gc, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33063 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/free5gc/ausf (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/ausf (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/ausf (Go): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33063/ (Markdown: https://insights.sbomify.com/CVE-2026-33063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33063
- OSV: https://osv.dev/vulnerability/CVE-2026-33063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33063/
Summaries are generated and may contain mistakes; the official description above is the record.
