# CVE-2026-33064: free5GC UDM DataChangeNotification Procedure Panic Due to Nil Pointer Dereference

> Remote attackers can crash the free5GC UDM service by sending crafted requests to the sdm-subscriptions endpoint, causing a denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-7g27-v5wj-jr75, GO-2026-4757, ROOT-OS-UBUNTU-2204-CVE-2026-33064

## What is CVE-2026-33064?

CVE-2026-33064 is a high-severity vulnerability in free5gc, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Free5GC is an open-source Linux Foundation project for 5th generation (5G) mobile core networks. Versions prior to 1.4.2 are vulnerable to procedure panic caused by Nil Pointer Dereference in the /sdm-subscriptions endpoint. A remote attacker can cause the UDM service to panic and crash by sending a crafted POST request to the /sdm-subscriptions endpoint with a malformed URL path containing path traversal sequences (../) and a large JSON payload. The DataChangeNotificationProcedure function in notifier.go attempts to access a nil pointer without proper validation, causing a complete service crash with "runtime error: invalid memory address or nil pointer dereference". Exploitation would result in UDM functionality disruption until recovery by restart. This issue has been fixed in version 1.4.2.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-478 (Missing Default Case in Multiple Condition Expression)

## Which versions are affected by CVE-2026-33064?

3 open source packages ship an affected version, including github.com/free5gc/udm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/udm` | Go | All versions | 1.4.2 |
| `github.com/free5gc/udm` | Go | All versions | 1.4.2 |
| `github.com/free5gc/udm` | Go | All versions | 1.4.2 |

Products: Free5gc Udm.

## How do I fix CVE-2026-33064?

Upgrade github.com/free5gc/udm to 1.4.2 or later.

## Is CVE-2026-33064 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33064 exists.

## Other vulnerabilities in free5gc

- [CVE-2026-33191](https://insights.sbomify.com/CVE-2026-33191/): free5GC UDM vulnerable to null byte injection in URL path parameters causing 500 Internal Server Error (high 8.7)
- [CVE-2026-33192](https://insights.sbomify.com/CVE-2026-33192/): free5GC UDM incorrectly returns 500 for empty supi path parameter in PATCH sdm-subscriptions reques (high 8.7)
- [CVE-2023-46324](https://insights.sbomify.com/CVE-2023-46324/): free5GC udm vulnerable to Invalid Curve Attack (high 7.5)
- [CVE-2026-33065](https://insights.sbomify.com/CVE-2026-33065/): free5GC UDM incorrectly returns 500 for empty supi path parameter in DELETE sdm-subscriptions request (medium 6.9)
- [CVE-2026-27642](https://insights.sbomify.com/CVE-2026-27642/): free5GC has Improper Input Validation in UDM UEAU Service (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33064 and fix it if it is affected.

What it is: CVE-2026-33064 is a high-severity vulnerability in free5gc, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33064 exists.

Affected packages and fixed versions:
- github.com/free5gc/udm (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/udm (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/udm (Go): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33064/ (Markdown: https://insights.sbomify.com/CVE-2026-33064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33064
- OSV: https://osv.dev/vulnerability/CVE-2026-33064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33064/
Summaries are generated and may contain mistakes; the official description above is the record.
