# CVE-2026-33065: free5GC UDM incorrectly returns 500 for empty supi path parameter in DELETE sdm-subscriptions request

> An attacker can trigger internal error handling leaks by sending malformed requests, revealing server-side failure details instead of standard client errors.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-958m-gxmc-mccm, GO-2026-4758, ROOT-OS-UBUNTU-2204-CVE-2026-33065

## What is CVE-2026-33065?

CVE-2026-33065 is a medium-severity vulnerability in free5gc, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Free5GC is an open-source Linux Foundation project for 5th generation (5G) mobile core networks. In versions prior to 1.4.2, the UDM incorrectly converts a downstream 400 Bad Request (from UDR) into a 500 Internal Server Error when handling DELETE requests with an empty supi path parameter. This leaks internal error handling behavior and makes it difficult for clients to distinguish between client-side errors and server-side failures. When a client sends a DELETE request with an empty supi (e.g., double slashes // in URL path), the UDM forwards the malformed request to UDR, which correctly returns 400. However, UDM propagates this as 500 SYSTEM_FAILURE instead of returning the appropriate 400 error to the client. This violates REST API best practices for DELETE operations. The issue has been patched in version 1.4.2.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-33065?

3 open source packages ship an affected version, including github.com/free5gc/udm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/udm` | Go | All versions | 1.4.2 |
| `github.com/free5gc/udm` | Go | All versions | 1.4.2 |
| `github.com/free5gc/udm` | Go | All versions | 1.4.2 |

Products: Free5gc Udm.

## How do I fix CVE-2026-33065?

Upgrade github.com/free5gc/udm to 1.4.2 or later.

## Is CVE-2026-33065 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33065 exists.

## Other vulnerabilities in free5gc

- [CVE-2026-33064](https://insights.sbomify.com/CVE-2026-33064/): free5GC UDM DataChangeNotification Procedure Panic Due to Nil Pointer Dereference (high 8.7)
- [CVE-2026-33191](https://insights.sbomify.com/CVE-2026-33191/): free5GC UDM vulnerable to null byte injection in URL path parameters causing 500 Internal Server Error (high 8.7)
- [CVE-2026-33192](https://insights.sbomify.com/CVE-2026-33192/): free5GC UDM incorrectly returns 500 for empty supi path parameter in PATCH sdm-subscriptions reques (high 8.7)
- [CVE-2023-46324](https://insights.sbomify.com/CVE-2023-46324/): free5GC udm vulnerable to Invalid Curve Attack (high 7.5)
- [CVE-2026-27642](https://insights.sbomify.com/CVE-2026-27642/): free5GC has Improper Input Validation in UDM UEAU Service (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33065 and fix it if it is affected.

What it is: CVE-2026-33065 is a medium-severity vulnerability in free5gc, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33065 exists.

Affected packages and fixed versions:
- github.com/free5gc/udm (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/udm (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/udm (Go): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33065/ (Markdown: https://insights.sbomify.com/CVE-2026-33065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33065
- OSV: https://osv.dev/vulnerability/CVE-2026-33065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33065/
Summaries are generated and may contain mistakes; the official description above is the record.
