CVE-2026-33073 discourse-subscriptions plugin leaking stripe API key in multisite environment

Low 2.0 Published Updated

The discourse-subscriptions plugin leaks Stripe API keys across sites in multisite clusters, exposing sensitive payment data to other tenants.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-33073?

CVE-2026-33073 is a low-severity vulnerability in Discourse Discourse, published on 31 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, the discourse-subscriptions plugin leaks stripe API keys across sites in a multisite cluster resulting in the potential for stripe related information to be leaked across sites within the same multisite cluster. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Weakness: CWE-200

Which versions are affected by CVE-2026-33073?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.3, 2026.2.2

Products include Discourse Discourse.

How do I fix CVE-2026-33073?

Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.

Is CVE-2026-33073 being exploited?

There is no known exploitation of CVE-2026-33073 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-33073, GHSA-f866-8fcp-fgvv.

Is CVE-2026-33073 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free