CVE-2026-33074 Discourse: Vulnerability in discourse-subscriptions plugin allowing users to self-grant to higher tier subscriptions

Medium 6.3 Published Updated

Users can self-grant higher-tier subscription benefits by purchasing lower tiers, requiring platform administrators to apply security patches.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33074?

CVE-2026-33074 is a medium-severity vulnerability in Discourse Discourse, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, a user may be able to purchase a lower tier subscription but grant themselves the benefits that comes along with a higher tier subscription. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Weakness: CWE-285, CWE-269

Which versions are affected by CVE-2026-33074?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.3, 2026.2.2

Products include Discourse Discourse.

How do I fix CVE-2026-33074?

Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.

Is CVE-2026-33074 being exploited?

There is no known exploitation of CVE-2026-33074 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-33074, GHSA-9vg5-mp49-xghh.

Is CVE-2026-33074 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free