# CVE-2026-33080: Filament: Unvalidated Range and Values summarizer values can be used for XSS

> Attackers can inject malicious scripts via unvalidated database values in Filament table summarizers, leading to stored XSS for viewing users.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** GHSA-vv3x-j2x5-36jc

## What is CVE-2026-33080?

CVE-2026-33080 is a high-severity cross-site scripting vulnerability in filamentphp filament, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.8.4 and 5.0.0 through 5.3.4 have two Filament Table summarizers (Range, Values) that render raw database values without escaping HTML. If there is a lack of validation for the data in the columns that use these summarizers, an attacker could plant malicious HTML / JavaScript and achieve stored XSS that executes for users who view the table with those summarizers. This issue has been patched in versions 4.8.5 and 5.3.5.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-33080?

4 open source packages ship an affected version, including filament/tables. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `filament/tables` | Packagist | From 4.0.0 | 4.8.5 |
| `filament/tables` | Packagist | From 4.0.0 | 4.8.5 |
| `filament/tables` | Packagist | From 5.0.0 | 5.3.5 |
| `filament/tables` | Packagist | From 5.0.0 | 5.3.5 |

Products: Filamentphp Filament.

## How do I fix CVE-2026-33080?

Upgrade filament/tables to a fixed version for your release line: 4.8.5 or 5.3.5.

## Is CVE-2026-33080 being exploited?

There is no known exploitation of CVE-2026-33080 in the wild and no public exploit code.

## Other vulnerabilities in filamentphp filament

- [CVE-2025-67507](https://insights.sbomify.com/CVE-2025-67507/): Filament's multi-factor authentication (app) recovery codes can be used multiple times (high 8.1)
- [CVE-2024-47186](https://insights.sbomify.com/CVE-2024-47186/): Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33080 and fix it if it is affected.

What it is: CVE-2026-33080 is a high-severity cross-site scripting vulnerability in filamentphp filament, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33080 in the wild and no public exploit code.

Affected packages and fixed versions:
- filament/tables (Packagist): affected from 4.0.0; fixed in 4.8.5
- filament/tables (Packagist): affected from 4.0.0; fixed in 4.8.5
- filament/tables (Packagist): affected from 5.0.0; fixed in 5.3.5
- filament/tables (Packagist): affected from 5.0.0; fixed in 5.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33080/ (Markdown: https://insights.sbomify.com/CVE-2026-33080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33080
- OSV: https://osv.dev/vulnerability/CVE-2026-33080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33080/
Summaries are generated and may contain mistakes; the official description above is the record.
