# CVE-2026-33081: PinchTab has Blind SSRF via browser-side redirect bypass in /download URL validation

> Attackers can force the PinchTab server to access internal network resources via blind SSRF if download functionality is enabled.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-qwxp-6qf9-wr4m, GO-2026-4748

## What is CVE-2026-33081?

CVE-2026-33081 is a medium-severity server-side request forgery vulnerability in pinchtab, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PinchTab is a standalone HTTP server that gives AI agents direct control over a Chrome browser. Versions 0.8.2 and below have a Blind SSRF vulnerability in the /download endpoint. The validateDownloadURL() function only checks the initial user-supplied URL, but the embedded Chromium browser can follow attacker-controlled redirects/navigations to internal network addresses after validation. Exploitation requires security.allowDownload=true (disabled by default), limiting real-world impact. An attacker-controlled page can use JavaScript redirects or resource requests to make the browser reach internal services from the PinchTab host, resulting in a blind Server-Side Request Forgery (SSRF) condition against internal-only services. The issue has been patched in version 0.8.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-33081?

3 open source packages ship an affected version, including github.com/pinchtab/pinchtab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pinchtab/pinchtab` | Go | All versions | 0.8.3 |
| `github.com/pinchtab/pinchtab` | Go | All versions | 0.8.3 |
| `github.com/pinchtab/pinchtab` | Go | All versions | 0.8.3 |

Products: Pinchtab Pinchtab.

## How do I fix CVE-2026-33081?

Upgrade github.com/pinchtab/pinchtab to 0.8.3 or later.

## Is CVE-2026-33081 being exploited?

There is no known exploitation of CVE-2026-33081 in the wild and no public exploit code.

## Other vulnerabilities in pinchtab

- [CVE-2026-30834](https://insights.sbomify.com/CVE-2026-30834/): PinchTab: SSRF with Full Response Exfiltration via Download Handler (high 7.5)
- [CVE-2026-33623](https://insights.sbomify.com/CVE-2026-33623/): PinchTab: OS Command Injection via Profile Name in Windows Cleanup Routine Enables Arbitrary Command Execution (medium 6.7)
- [CVE-2026-33622](https://insights.sbomify.com/CVE-2026-33622/): A PinchTab Security Policy Bypass in /wait Allows Arbitrary JavaScript Execution (medium 6.1)
- [CVE-2026-33621](https://insights.sbomify.com/CVE-2026-33621/): PinchTab: Unapplied Rate Limiting Middleware Allows Unbounded Brute-Force of API Token (medium 4.8)
- [CVE-2026-33620](https://insights.sbomify.com/CVE-2026-33620/): PinchTab: API Bearer Token Exposed in URL Query Parameter via Server Logs and Intermediary Systems (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33081 and fix it if it is affected.

What it is: CVE-2026-33081 is a medium-severity server-side request forgery vulnerability in pinchtab, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33081 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pinchtab/pinchtab (Go): affected all versions; fixed in 0.8.3
- github.com/pinchtab/pinchtab (Go): affected all versions; fixed in 0.8.3
- github.com/pinchtab/pinchtab (Go): affected all versions; fixed in 0.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33081/ (Markdown: https://insights.sbomify.com/CVE-2026-33081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33081
- OSV: https://osv.dev/vulnerability/CVE-2026-33081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33081/
Summaries are generated and may contain mistakes; the official description above is the record.
