# CVE-2026-33124: Frigate has insecure password change functionality

> Authenticated users can change passwords without current password verification, allowing attackers with stolen tokens to permanently hijack accounts.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-24p8-r573-vwr2

## What is CVE-2026-33124?

CVE-2026-33124 is a high-severity authentication bypass vulnerability in blakeblackshear frigate, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frigate is a network video recorder (NVR) with realtime local object detection for IP cameras. Versions prior to 0.17.0-beta1 allow any authenticated user to change their own password without verifying the current password through the /users/{username}/password endpoint. Changing a password does not invalidate existing JWT tokens, and there is no validation of password strength. If an attacker obtains a valid session token (e.g., via accidentally exposed JWT, stolen cookie, XSS, compromised device, or sniffing over HTTP), they can change the victim’s password and gain permanent control of the account. Since password changes do not invalidate existing JWT tokens, session hijacks persist even after a password reset. Additionally, the lack of password strength validation exposes accounts to brute-force attacks. This issue has been resolved in version 0.17.0-beta1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-33124?

It affects 1 product.


Products: Frigate Frigate.

## How do I fix CVE-2026-33124?

No fix has been published for CVE-2026-33124 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33124 being exploited?

There is no known exploitation of CVE-2026-33124 in the wild and no public exploit code.

## Other vulnerabilities in blakeblackshear frigate

- [CVE-2026-25643](https://insights.sbomify.com/CVE-2026-25643/): Frigate Affected by Authenticated Remote Command Execution (RCE) and Container Escape (critical 9.1)
- [CVE-2023-45670](https://insights.sbomify.com/CVE-2023-45670/): Frigate cross-site request forgery in `config_save` and `config_set` request handlers (high 7.5)
- [CVE-2023-45672](https://insights.sbomify.com/CVE-2023-45672/): Frigate unsafe deserialization in `load_config_with_no_duplicates` of `frigate/util/builtin.py` (high 7.5)
- [CVE-2026-33125](https://insights.sbomify.com/CVE-2026-33125/): Frigate Broken Access Control: Users assigned the viewer role can delete admin and other low-privileged accounts (high 7.1)
- [CVE-2026-33469](https://insights.sbomify.com/CVE-2026-33469/): Authenticated Frigate users can read the full unredacted configuration via `/api/config/raw (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33124 and fix it if it is affected.

What it is: CVE-2026-33124 is a high-severity authentication bypass vulnerability in blakeblackshear frigate, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33124 in the wild and no public exploit code.

Affected product: blakeblackshear frigate. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33124/ (Markdown: https://insights.sbomify.com/CVE-2026-33124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33124
- OSV: https://osv.dev/vulnerability/CVE-2026-33124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33124/
Summaries are generated and may contain mistakes; the official description above is the record.
