# CVE-2026-33137: XWiki Platform has an Unauthenticated XAR Import via REST /wikis/{wikiName}

> Unauthenticated attackers can import XAR files via REST API to create or update documents, potentially leading to code execution.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-qrvh-r3f2-9h4r

## What is CVE-2026-33137?

CVE-2026-33137 is a critical missing authorization vulnerability in xwiki-platform, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. XWiki Platform is a generic wiki platform. In versions starting with 15.10.6 and prior to 18.1.0-rc-1, 17.10.3, 17.4.9, and 16.10.17, the POST /wikis/{wikiName} API executes a XAR import without performing any authentication or authorization checks, allowing an unauthenticated attacker to create or update documents in the target wiki. This vulnerability has been patched in XWiki 16.10.17, 17.4.9, 17.10.3, 18.0.1 and 18.1.0-rc-1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-33137?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rest-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 15.10.6 | 16.10.17 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 15.10.6 | 16.10.17 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.0.0-rc-1 | 17.4.9 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.0.0-rc-1 | 17.4.9 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.5.0 | 17.10.3 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.5.0 | 17.10.3 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 18.0.0-rc-1 | 18.1.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 18.0.0-rc-1 | 18.1.0-rc-1 |

## How do I fix CVE-2026-33137?

Upgrade org.xwiki.platform:xwiki-platform-rest-server to a fixed version for your release line: 16.10.17, 17.4.9, 17.10.3 or 18.1.0-rc-1.

## Is CVE-2026-33137 being exploited?

There is no known exploitation of CVE-2026-33137 in the wild and no public exploit code.

Public exploit code:

- XWiki Platform - CVE-2026-33137 PoC - Unauthenticated XAR Import via REST /wikis/{wikiName} (github_poc): https://github.com/portbuster1337/CVE-2026-33137

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33137 and fix it if it is affected.

What it is: CVE-2026-33137 is a critical missing authorization vulnerability in xwiki-platform, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33137 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 15.10.6; fixed in 16.10.17
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 15.10.6; fixed in 16.10.17
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.0.0-rc-1; fixed in 17.4.9
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.0.0-rc-1; fixed in 17.4.9
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.5.0; fixed in 17.10.3
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.5.0; fixed in 17.10.3
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 18.0.0-rc-1; fixed in 18.1.0-rc-1
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 18.0.0-rc-1; fixed in 18.1.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33137/ (Markdown: https://insights.sbomify.com/CVE-2026-33137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33137
- OSV: https://osv.dev/vulnerability/CVE-2026-33137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33137/
Summaries are generated and may contain mistakes; the official description above is the record.
