# CVE-2026-33139: PySpector: Plugin Sandbox Bypass leads to Arbitrary Code Execution

> Attackers can bypass plugin security checks in PySpector to execute arbitrary code on the developer's machine via indirect function calls.

- **Severity:** High 8.3 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-v3xv-8vc3-h2m6, PYSEC-2026-3030

## What is CVE-2026-33139?

CVE-2026-33139 is a high-severity code injection vulnerability in ParzivalHack PySpector, published on 20 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PySpector is a static analysis security testing (SAST) Framework engineered for modern Python development workflows. PySpector versions 0.1.6 and prior are affected by a security validation bypass in the plugin system. The validate_plugin_code() function in plugin_system.py, performs static AST analysis to block dangerous API calls before a plugin is trusted and executed. However, the internal resolve_name() helper only handles ast.Name and ast.Attribute node types, returning None for all others. When a plugin uses indirect function calls via getattr() (such as getattr(os, 'system')) the outer call's func node is of type ast.Call, causing resolve_name() to return None, and the security check to be silently skipped. The plugin incorrectly passes the trust workflow, and executes arbitrary system commands on the user's machine when loaded. This issue has been patched in version 0.1.7.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-33139?

3 open source packages ship an affected version, including pyspector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyspector` | PyPI | All versions | 0.1.7 |
| `pyspector` | PyPI | All versions | 0.1.7 |
| `pyspector` | PyPI | All versions | 0.1.7 |

Products: Parzivalhack Pyspector.

## How do I fix CVE-2026-33139?

Upgrade pyspector to 0.1.7 or later.

## Is CVE-2026-33139 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33139 exists.

## Other vulnerabilities in ParzivalHack PySpector

- [CVE-2026-41206](https://insights.sbomify.com/CVE-2026-41206/): PySpector has a Plugin Code Execution Bypass via Incomplete Static Analysis in PluginSecurity.validate_plugin_code (medium 6.9)
- [CVE-2026-33140](https://insights.sbomify.com/CVE-2026-33140/): PySpector: Stored XSS in PySpector HTML Report Generation leads to Javascript Code Execution (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33139 and fix it if it is affected.

What it is: CVE-2026-33139 is a high-severity code injection vulnerability in ParzivalHack PySpector, published on 20 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33139 exists.

Affected packages and fixed versions:
- pyspector (PyPI): affected all versions; fixed in 0.1.7
- pyspector (PyPI): affected all versions; fixed in 0.1.7
- pyspector (PyPI): affected all versions; fixed in 0.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33139/ (Markdown: https://insights.sbomify.com/CVE-2026-33139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33139
- OSV: https://osv.dev/vulnerability/CVE-2026-33139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33139/
Summaries are generated and may contain mistakes; the official description above is the record.
