# CVE-2026-33140: PySpector: Stored XSS in PySpector HTML Report Generation leads to Javascript Code Execution

> Attackers can execute arbitrary JavaScript in a developer's browser by crafting Python files that trigger unsanitized output in PySpector HTML reports.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-2gmv-2r3v-jxj2, PYSEC-2026-3029

## What is CVE-2026-33140?

CVE-2026-33140 is a medium-severity cross-site scripting vulnerability in ParzivalHack PySpector, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PySpector is a static analysis security testing (SAST) Framework engineered for modern Python development workflows. PySpector versions 0.1.6 and prior are affected by a stored Cross-Site Scripting (XSS) vulnerability in the HTML report generator. When PySpector scans a Python file containing JavaScript payloads (i.e. inside a string passed to eval() ), the flagged code snippet is interpolated into the HTML report without sanitization. Opening the generated report in a browser causes the embedded JavaScript to execute in the browser's local file context. This issue has been patched in version 0.1.7.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-33140?

3 open source packages ship an affected version, including pyspector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyspector` | PyPI | All versions | 0.1.7 |
| `pyspector` | PyPI | All versions | 0.1.7 |
| `pyspector` | PyPI | All versions | 0.1.7 |

Products: Parzivalhack Pyspector.

## How do I fix CVE-2026-33140?

Upgrade pyspector to 0.1.7 or later.

## Is CVE-2026-33140 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33140 exists.

## Other vulnerabilities in ParzivalHack PySpector

- [CVE-2026-33139](https://insights.sbomify.com/CVE-2026-33139/): PySpector: Plugin Sandbox Bypass leads to Arbitrary Code Execution (high 8.3)
- [CVE-2026-41206](https://insights.sbomify.com/CVE-2026-41206/): PySpector has a Plugin Code Execution Bypass via Incomplete Static Analysis in PluginSecurity.validate_plugin_code (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33140 and fix it if it is affected.

What it is: CVE-2026-33140 is a medium-severity cross-site scripting vulnerability in ParzivalHack PySpector, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33140 exists.

Affected packages and fixed versions:
- pyspector (PyPI): affected all versions; fixed in 0.1.7
- pyspector (PyPI): affected all versions; fixed in 0.1.7
- pyspector (PyPI): affected all versions; fixed in 0.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33140/ (Markdown: https://insights.sbomify.com/CVE-2026-33140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33140
- OSV: https://osv.dev/vulnerability/CVE-2026-33140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33140/
Summaries are generated and may contain mistakes; the official description above is the record.
