# CVE-2026-33151: socket.io allows an unbounded number of binary attachments

> Attackers can cause server memory exhaustion by sending crafted packets with excessive binary attachments, leading to denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 23 Mar 2026
- **Also known as:** CLSA-2026-1779324474, CLSA-2026-1779324475, CLSA-2026-1779324477, CLSA-2026-1784769501, DEBIAN-CVE-2026-33151, GHSA-677m-j7p3-52f9, ROOT-APP-NPM-CVE-2026-33151, UBUNTU-CVE-2026-33151

## What is CVE-2026-33151?

CVE-2026-33151 is a high-severity denial of service vulnerability in socketio socket.io, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Socket.IO is an open source, real-time, bidirectional, event-based, communication framework. Prior to versions 3.3.5, 3.4.4, and 4.2.6, a specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory. This issue has been patched in versions 3.3.5, 3.4.4, and 4.2.6.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-33151?

6 open source packages ship an affected version, including socket.io-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `socket.io-parser` | npm | All versions | 3.3.5 |
| `socket.io-parser` | npm | All versions | 3.3.5 |
| `socket.io-parser` | npm | From 3.4.0 | 3.4.4 |
| `socket.io-parser` | npm | From 3.4.0 | 3.4.4 |
| `socket.io-parser` | npm | From 4.0.0 | 4.2.6 |
| `socket.io-parser` | npm | From 4.0.0 | 4.2.6 |

Products: Socket Socket.io-Parser.

## How do I fix CVE-2026-33151?

Upgrade socket.io-parser to a fixed version for your release line: 3.3.5, 3.4.4 or 4.2.6.

## Is CVE-2026-33151 being exploited?

There is no known exploitation of CVE-2026-33151 in the wild and no public exploit code.

## Other vulnerabilities in socketio socket.io

- [CVE-2022-2421](https://insights.sbomify.com/CVE-2022-2421/): Socket.io - Improper type validation in attachment parsing (critical 10.0)
- [CVE-2020-36049](https://insights.sbomify.com/CVE-2020-36049/): Resource exhaustion in socket.io-parser (high 7.5)
- [CVE-2023-32695](https://insights.sbomify.com/CVE-2023-32695/): Insufficient validation when decoding a Socket.IO packet (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33151 and fix it if it is affected.

What it is: CVE-2026-33151 is a high-severity denial of service vulnerability in socketio socket.io, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33151 in the wild and no public exploit code.

Affected packages and fixed versions:
- socket.io-parser (npm): affected all versions; fixed in 3.3.5
- socket.io-parser (npm): affected all versions; fixed in 3.3.5
- socket.io-parser (npm): affected from 3.4.0; fixed in 3.4.4
- socket.io-parser (npm): affected from 3.4.0; fixed in 3.4.4
- socket.io-parser (npm): affected from 4.0.0; fixed in 4.2.6
- socket.io-parser (npm): affected from 4.0.0; fixed in 4.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33151/ (Markdown: https://insights.sbomify.com/CVE-2026-33151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33151
- OSV: https://osv.dev/vulnerability/CVE-2026-33151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33151/
Summaries are generated and may contain mistakes; the official description above is the record.
