# CVE-2026-33154: dynaconf Affected by Remote Code Execution (RCE) via Insecure Template Evaluation in @jinja Resolver

> Attackers can execute arbitrary code via Server-Side Template Injection in dynaconf when the jinja2 package is installed and templates are evaluated.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33154, GHSA-pxrr-hq57-q35p, PYSEC-2026-2147, UBUNTU-CVE-2026-33154, USN-8231-1, openSUSE-SU-2026:10411-1, openSUSE-SU-2026:20429-1

## What is CVE-2026-33154?

CVE-2026-33154 is a high-severity code injection vulnerability in dynaconf, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

dynaconf is a configuration management tool for Python. Prior to version 3.2.13, Dynaconf is vulnerable to Server-Side Template Injection (SSTI) due to unsafe template evaluation in the @Jinja resolver. When the jinja2 package is installed, Dynaconf evaluates template expressions embedded in configuration values without a sandboxed environment. This issue has been patched in version 3.2.13.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-33154?

3 open source packages ship an affected version, including dynaconf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dynaconf` | PyPI | All versions | 3.2.13 |
| `dynaconf` | PyPI | All versions | 3.2.13 |
| `dynaconf` | PyPI | All versions | 3.2.13 |
| `python-dynaconf` | openSUSE:Leap 16.0 | All versions | 3.2.5-bp160.2.1 |
| `python-dynaconf` | openSUSE:Tumbleweed | All versions | 3.2.13-1.1 |

Products: Dynaconf Dynaconf.

## How do I fix CVE-2026-33154?

Upgrade dynaconf to 3.2.13 or later.

## Is CVE-2026-33154 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33154 exists.

Public exploit code:

- CVE-2026-33154(RCE @jinja resolver) (github_poc): https://github.com/redyank/CVE-2026-33154

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33154 and fix it if it is affected.

What it is: CVE-2026-33154 is a high-severity code injection vulnerability in dynaconf, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33154 exists.

Affected packages and fixed versions:
- dynaconf (PyPI): affected all versions; fixed in 3.2.13
- dynaconf (PyPI): affected all versions; fixed in 3.2.13
- dynaconf (PyPI): affected all versions; fixed in 3.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33154/ (Markdown: https://insights.sbomify.com/CVE-2026-33154/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33154
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33154
- OSV: https://osv.dev/vulnerability/CVE-2026-33154

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33154/
Summaries are generated and may contain mistakes; the official description above is the record.
