# CVE-2026-33155: DeepDiff has Memory Exhaustion DoS through SAFE_TO_IMPORT

> An attacker can cause memory exhaustion and denial of service in applications using DeepDiff by providing a small malicious pickle payload.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** CLSA-2026-1781139163, DEBIAN-CVE-2026-33155, GHSA-54jj-px8x-5w5q, MINI-8g99-r865-r32p, PYSEC-2026-2445, SUSE-SU-2026:1094-1, UBUNTU-CVE-2026-33155, openSUSE-SU-2026:10417-1

## What is CVE-2026-33155?

CVE-2026-33155 is a high-severity denial of service vulnerability in seperman deepdiff, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DeepDiff is a project focused on Deep Difference and search of any Python data. From version 5.0.0 to before version 8.6.2, the pickle unpickler _RestrictedUnpickler validates which classes can be loaded but does not limit their constructor arguments. A few of the types in SAFE_TO_IMPORT have constructors that allocate memory proportional to their input (builtins.bytes, builtins.list, builtins.range). A 40-byte pickle payload can force 10+ GB of memory, which crashes applications that load delta objects or call pickle_load with untrusted data. This issue has been patched in version 8.6.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-33155?

3 open source packages ship an affected version, including deepdiff. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deepdiff` | PyPI | From 5.0.0 | 8.6.2 |
| `deepdiff` | PyPI | From 5.0.0 | 8.6.2 |
| `deepdiff` | PyPI | From 5.0.0 | 8.6.2 |
| `python-deepdiff` | openSUSE:Leap 15.6 | All versions | 6.3.0-150600.3.6.1 |
| `python-deepdiff` | openSUSE:Tumbleweed | All versions | 8.6.2-1.1 |

Products: Qluster Deepdiff.

## How do I fix CVE-2026-33155?

Upgrade deepdiff to 8.6.2 or later.

## Is CVE-2026-33155 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33155 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33155 and fix it if it is affected.

What it is: CVE-2026-33155 is a high-severity denial of service vulnerability in seperman deepdiff, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33155 exists.

Affected packages and fixed versions:
- deepdiff (PyPI): affected from 5.0.0; fixed in 8.6.2
- deepdiff (PyPI): affected from 5.0.0; fixed in 8.6.2
- deepdiff (PyPI): affected from 5.0.0; fixed in 8.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33155/ (Markdown: https://insights.sbomify.com/CVE-2026-33155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33155
- OSV: https://osv.dev/vulnerability/CVE-2026-33155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33155/
Summaries are generated and may contain mistakes; the official description above is the record.
