CVE-2026-33159 Craft CMS: Unauthenticated Users Can Perform Restricted Project Config Sync Operations
Unauthenticated attackers can execute restricted project configuration sync operations in Craft CMS, allowing unauthorized state changes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33159?
CVE-2026-33159 is a medium-severity missing authorization vulnerability in Craftcms Craft Cms, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.8 and from version 5.0.0-RC1 to before version 5.9.14, guest users can access Config Sync updater index, obtain signed data, and execute state-changing Config Sync actions (regenerate-yaml, apply-yaml-changes) without authentication. This issue has been patched in versions 4.17.8 and 5.9.14.
Which versions are affected by CVE-2026-33159?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.8 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.8 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.14 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.14 |
Products include Craftcms Craft Cms.
How do I fix CVE-2026-33159?
Upgrade craftcms/cms to a fixed version for your release line: 4.17.8 or 5.9.14.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-33159 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33159 exists.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-6mrr-q3pj-h53w.