# CVE-2026-33160: Craft CMS: Anonymous "generate transform" calls for assets can expose private assets via transform URL

> Unauthenticated attackers can access private asset images by exploiting missing authorization checks in the asset transform generation endpoint.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** GHSA-5pgf-h923-m958

## What is CVE-2026-33160?

CVE-2026-33160 is a low-severity missing authorization vulnerability in Craftcms Craft Cms, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.8 and from version 5.0.0-RC1 to before version 5.9.14, an unauthenticated user can call assets/generate-transform with a private assetId, receive a valid transform URL, and fetch transformed image bytes. The endpoint is anonymous and does not enforce per-asset authorization before returning the transform URL. This issue has been patched in versions 4.17.8 and 5.9.14.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-33160?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.8 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.8 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.14 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.14 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-33160?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.8 or 5.9.14.

## Is CVE-2026-33160 being exploited?

There is no known exploitation of CVE-2026-33160 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33160 and fix it if it is affected.

What it is: CVE-2026-33160 is a low-severity missing authorization vulnerability in Craftcms Craft Cms, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33160 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.8
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.8
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.14
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33160/ (Markdown: https://insights.sbomify.com/CVE-2026-33160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33160
- OSV: https://osv.dev/vulnerability/CVE-2026-33160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33160/
Summaries are generated and may contain mistakes; the official description above is the record.
