CVE-2026-33163 Parse Server leaks protected fields via LiveQuery afterEvent trigger
Attackers can read protected fields and authData of other users via LiveQuery if an afterLiveQueryEvent trigger is registered.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33163?
CVE-2026-33163 is a high-severity vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.35 and 8.6.50, when a `Parse.Cloud.afterLiveQueryEvent` trigger is registered for a class, the LiveQuery server leaks protected fields and `authData` to all subscribers of that class. Fields configured as protected via Class-Level Permissions (`protectedFields`) are included in LiveQuery event payloads for all event types (create, update, delete, enter, leave). Any user with sufficient CLP permissions to subscribe to the affected class can receive protected field data of other users, including sensitive personal information and OAuth tokens from third-party authentication providers. The vulnerability was caused by a reference detachment bug. When an `afterEvent` trigger is registered, the LiveQuery server converts the event object to a `Parse.Object` for the trigger, then creates a new JSON copy via `toJSONwithObjects()`. The sensitive data filter was applied to the `Parse.Object` reference, but the unfiltered JSON copy was sent to clients. The fix in versions 9.6.0-alpha.35 and 8.6.50 ensures that the JSON copy is assigned back to the response object before filtering, so the filter operates on the actual data sent to clients. As a workaround, remove all `Parse.Cloud.afterLiveQueryEvent` trigger registrations. Without an `afterEvent` trigger, the reference detachment does not occur and protected fields are correctly filtered.
Weakness: CWE-200
Which versions are affected by CVE-2026-33163?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.50 |
parse-server npm | All versions | 8.6.50 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.35 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.35 |
parse Bitnami | All versions | 8.6.50, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-33163?
Upgrade parse-server to a fixed version for your release line: 8.6.50 or 9.6.0-alpha.35.
Is CVE-2026-33163 being exploited?
There is no known exploitation of CVE-2026-33163 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-33163, GHSA-5hmj-jcgp-6hff.