# CVE-2026-33173: Rails Active Storage has possible content type bypass via metadata in direct uploads

> Attackers can bypass content type validations in Rails Active Storage direct uploads by manipulating metadata flags to skip MIME detection.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33173, GHSA-qcfx-2mfw-w4cg, UBUNTU-CVE-2026-33173

## What is CVE-2026-33173?

CVE-2026-33173 is a medium-severity vulnerability in Rubyonrails Rails, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Active Storage allows users to attach cloud and local files in Rails applications. Prior to versions 8.1.2.1, 8.0.4.1, and 7.2.3.1, `DirectUploadsController` accepts arbitrary metadata from the client and persists it on the blob. Because internal flags like `identified` and `analyzed` are stored in the same metadata hash, a direct-upload client can set these flags to skip MIME detection and analysis. This allows an attacker to upload arbitrary content while claiming a safe `content_type`, bypassing any validations that rely on Active Storage's automatic content type identification. Versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 contain a patch.

Weakness: CWE-925 (Improper Verification of Intent by Broadcast Receiver)

## Which versions are affected by CVE-2026-33173?

6 open source packages ship an affected version, including activestorage. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activestorage` | RubyGems | All versions | 7.2.3.1 |
| `activestorage` | RubyGems | All versions | 7.2.3.1 |
| `activestorage` | RubyGems | From 8.0.0.beta1 | 8.0.4.1 |
| `activestorage` | RubyGems | From 8.0.0.beta1 | 8.0.4.1 |
| `activestorage` | RubyGems | From 8.1.0.beta1 | 8.1.2.1 |
| `activestorage` | RubyGems | From 8.1.0.beta1 | 8.1.2.1 |

Products: Rubyonrails Rails.

## How do I fix CVE-2026-33173?

Upgrade activestorage to a fixed version for your release line: 7.2.3.1, 8.0.4.1 or 8.1.2.1.

## Is CVE-2026-33173 being exploited?

There is no known exploitation of CVE-2026-33173 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33173 and fix it if it is affected.

What it is: CVE-2026-33173 is a medium-severity vulnerability in Rubyonrails Rails, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33173 in the wild and no public exploit code.

Affected packages and fixed versions:
- activestorage (RubyGems): affected all versions; fixed in 7.2.3.1
- activestorage (RubyGems): affected all versions; fixed in 7.2.3.1
- activestorage (RubyGems): affected from 8.0.0.beta1; fixed in 8.0.4.1
- activestorage (RubyGems): affected from 8.0.0.beta1; fixed in 8.0.4.1
- activestorage (RubyGems): affected from 8.1.0.beta1; fixed in 8.1.2.1
- activestorage (RubyGems): affected from 8.1.0.beta1; fixed in 8.1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33173/ (Markdown: https://insights.sbomify.com/CVE-2026-33173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33173
- OSV: https://osv.dev/vulnerability/CVE-2026-33173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33173/
Summaries are generated and may contain mistakes; the official description above is the record.
