# CVE-2026-33176: Rails Active Support has a possible DoS vulnerability in its number helpers

> Attackers can cause denial of service in Rails applications by submitting scientific notation strings that trigger excessive resource consumption in Active Support number helpers.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33176, GHSA-2j26-frm8-cmj9, MINI-47qx-crvf-ffcf, MINI-jf4x-2566-cr56, MINI-rp5m-p5x3-w4rr, UBUNTU-CVE-2026-33176

## What is CVE-2026-33176?

CVE-2026-33176 is a medium-severity denial of service vulnerability in Rubyonrails Rails, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Active Support is a toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Prior to versions 8.1.2.1, 8.0.4.1, and 7.2.3.1, Active Support number helpers accept strings containing scientific notation (e.g. `1e10000`), which `BigDecimal` expands into extremely large decimal representations. This can cause excessive memory allocation and CPU consumption when the expanded number is formatted, possibly resulting in a DoS vulnerability. Versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 contain a patch.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-33176?

6 open source packages ship an affected version, including activesupport. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activesupport` | RubyGems | All versions | 7.2.3.1 |
| `activesupport` | RubyGems | All versions | 7.2.3.1 |
| `activesupport` | RubyGems | From 8.0.0.beta1 | 8.0.4.1 |
| `activesupport` | RubyGems | From 8.0.0.beta1 | 8.0.4.1 |
| `activesupport` | RubyGems | From 8.1.0.beta1 | 8.1.2.1 |
| `activesupport` | RubyGems | From 8.1.0.beta1 | 8.1.2.1 |

Products: Rubyonrails Rails.

## How do I fix CVE-2026-33176?

Upgrade activesupport to a fixed version for your release line: 7.2.3.1, 8.0.4.1 or 8.1.2.1.

## Is CVE-2026-33176 being exploited?

There is no known exploitation of CVE-2026-33176 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33176 and fix it if it is affected.

What it is: CVE-2026-33176 is a medium-severity denial of service vulnerability in Rubyonrails Rails, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33176 in the wild and no public exploit code.

Affected packages and fixed versions:
- activesupport (RubyGems): affected all versions; fixed in 7.2.3.1
- activesupport (RubyGems): affected all versions; fixed in 7.2.3.1
- activesupport (RubyGems): affected from 8.0.0.beta1; fixed in 8.0.4.1
- activesupport (RubyGems): affected from 8.0.0.beta1; fixed in 8.0.4.1
- activesupport (RubyGems): affected from 8.1.0.beta1; fixed in 8.1.2.1
- activesupport (RubyGems): affected from 8.1.0.beta1; fixed in 8.1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33176/ (Markdown: https://insights.sbomify.com/CVE-2026-33176/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33176
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33176
- OSV: https://osv.dev/vulnerability/CVE-2026-33176

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33176/
Summaries are generated and may contain mistakes; the official description above is the record.
