# CVE-2026-33180: HAPI FHIR HTTP authentication leak in redirects

> HAPI FHIR leaks sensitive HTTP headers to redirect targets, potentially exposing privacy data or enabling client impersonation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-p7m9-v2cm-2h7m, ROOT-APP-MAVEN-CVE-2026-33180

## What is CVE-2026-33180?

CVE-2026-33180 is a high-severity vulnerability in hapifhir org.hl7.fhir.core, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to version 6.9.0, when setting headers in HTTP requests, the internal HTTP client sends headers first to the host in the initial URL but also, if asked to follow redirects and a 30X HTTP response code is returned, to the host mentioned in URL in the Location: response header value. Sending the same set of headers to subsequent hosts is a problem as this header often contains privacy sensitive information or data that could allow others to impersonate the  client's request. This issue has been patched in release 6.9.0. No known workarounds are available.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-33180?

24 open source packages ship an affected version, including ca.uhn.hapi.fhir:org.hl7.fhir.convertors, ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 and ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ca.uhn.hapi.fhir:org.hl7.fhir.convertors` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.convertors` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3.support` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3.support` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.model` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.model` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4b` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4b` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.utilities` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.utilities` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli` | Maven | All versions | 6.9.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli` | Maven | All versions | 6.9.0 |

## How do I fix CVE-2026-33180?

Upgrade ca.uhn.hapi.fhir:org.hl7.fhir.convertors to 6.9.0 or later.

## Is CVE-2026-33180 being exploited?

There is no known exploitation of CVE-2026-33180 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33180 and fix it if it is affected.

What it is: CVE-2026-33180 is a high-severity vulnerability in hapifhir org.hl7.fhir.core, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33180 in the wild and no public exploit code.

Affected packages and fixed versions:
- ca.uhn.hapi.fhir:org.hl7.fhir.convertors (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.convertors (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3.support (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3.support (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.model (Maven): affected all versions; fixed in 6.9.0
- ca.uhn.hapi.fhir:org.hl7.fhir.model (Maven): affected all versions; fixed in 6.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33180/ (Markdown: https://insights.sbomify.com/CVE-2026-33180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33180
- OSV: https://osv.dev/vulnerability/CVE-2026-33180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33180/
Summaries are generated and may contain mistakes; the official description above is the record.
