{"answers":{"affected":"2 open source packages ship an affected version, including saloonphp/saloon. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33182 in the wild and no public exploit code.","fix":"Upgrade saloonphp/saloon to 4.0.0 or later.","what":"CVE-2026-33182 is a medium-severity server-side request forgery vulnerability in saloonphp saloon, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33182 and fix it if it is affected.\n\nWhat it is: CVE-2026-33182 is a medium-severity server-side request forgery vulnerability in saloonphp saloon, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-33182 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- saloonphp/saloon (Packagist): affected all versions; fixed in 4.0.0\n- saloonphp/saloon (Packagist): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33182/ (Markdown: https://insights.sbomify.com/CVE-2026-33182/index.md)","id":"CVE-2026-33182","markdown":"https://insights.sbomify.com/CVE-2026-33182/index.md","name":"CVE-2026-33182","record":{"aliases":["GHSA-c83f-3xp6-hfcp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP API integration library","requires_auth":"none","summary":"Attackers can trigger SSRF and leak credentials by supplying absolute URLs in API endpoints, affecting developers using the Saloon PHP library.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"saloon","vendor":"saloon"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Saloon is a PHP library that gives users tools to build API integrations and SDKs. Prior to version 4.0.0, when building the request URL, Saloon combined the connector's base URL with the request endpoint. If the endpoint was a valid absolute URL, the code used that URL as-is and ignored the base URL. The request—and any authentication headers, cookies, or tokens attached by the connector—was then sent to the attacker-controlled host. If the endpoint could be influenced by user input or configuration (e.g. redirect_uri, callback URL), this allowed server-side request forgery (SSRF) and/or credential leakage to a third-party host. The fix in version 4.0.0 is to reject absolute URLs in the endpoint: URLHelper::join() throws InvalidArgumentException when the endpoint is a valid absolute URL, unless explicitly allowed, requiring callers to opt-in to the functionality on a per-connector or per-request basis.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Saloon is vulnerable to SSRF and credential leakage via absolute URL in endpoint overriding base URL","id":"CVE-2026-33182","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Saloon has a Fixture Name Path Traversal Vulnerability","id":"CVE-2026-33183"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"saloonphp/saloon","purl":null,"source":"GHSA-c83f-3xp6-hfcp"},{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"saloonphp/saloon","purl":"pkg:composer/saloonphp/saloon","source":"GHSA-c83f-3xp6-hfcp"}],"prev":{"headline":"HAPI FHIR HTTP authentication leak in redirects","id":"CVE-2026-33180"},"products":["saloon"],"published":"2026-03-26","related":[{"cvss_score":8.1,"headline":"Saloon has insecure deserialization in AccessTokenAuthenticator (object injection / RCE)","id":"CVE-2026-33942","kev_date_added":null,"published":"2026-03-26"},{"cvss_score":8,"headline":"Saloon has a Fixture Name Path Traversal Vulnerability","id":"CVE-2026-33183","kev_date_added":null,"published":"2026-03-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-26","vendors":["saloonphp"]},"summary":"Attackers can trigger SSRF and leak credentials by supplying absolute URLs in API endpoints, affecting developers using the Saloon PHP library.","url":"https://insights.sbomify.com/CVE-2026-33182/"}