# CVE-2026-33204: SimpleJWT has an Unauthenticated Denial of Service via JWE header tampering

> An unauthenticated attacker can cause a denial of service in applications using SimpleJWT by tampering with JWE headers when PBES2 algorithms are enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-xw36-67f8-339x

## What is CVE-2026-33204?

CVE-2026-33204 is a high-severity denial of service vulnerability in kelvinmo simplejwt, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SimpleJWT is a simple JSON web token library written in PHP. Prior to version 1.1.1, an unauthenticated attacker can perform a Denial of Service via JWE header tampering when PBES2 algorithms are used. Applications that call JWE::decrypt() on attacker-controlled JWEs using PBES2 algorithms are affected. This issue has been patched in version 1.1.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-33204?

2 open source packages ship an affected version, including kelvinmo/simplejwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kelvinmo/simplejwt` | Packagist | All versions | 1.1.1 |
| `kelvinmo/simplejwt` | Packagist | All versions | 1.1.1 |

Products: Kelvinmo Simplejwt.

## How do I fix CVE-2026-33204?

Upgrade kelvinmo/simplejwt to 1.1.1 or later.

## Is CVE-2026-33204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33204 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33204 and fix it if it is affected.

What it is: CVE-2026-33204 is a high-severity denial of service vulnerability in kelvinmo simplejwt, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33204 exists.

Affected packages and fixed versions:
- kelvinmo/simplejwt (Packagist): affected all versions; fixed in 1.1.1
- kelvinmo/simplejwt (Packagist): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33204/ (Markdown: https://insights.sbomify.com/CVE-2026-33204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33204
- OSV: https://osv.dev/vulnerability/CVE-2026-33204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33204/
Summaries are generated and may contain mistakes; the official description above is the record.
