{"answers":{"affected":"6 open source packages ship an affected version, including json. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33210 in the wild and no public exploit code.","fix":"Upgrade json to a fixed version for your release line: 2.15.2.1, 2.17.1.2 or 2.19.2.","what":"CVE-2026-33210 is a high-severity vulnerability in ruby json, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33210 and fix it if it is affected.\n\nWhat it is: CVE-2026-33210 is a high-severity vulnerability in ruby json, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-33210 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- json (RubyGems): affected from 2.14.0; fixed in 2.15.2.1\n- json (RubyGems): affected from 2.14.0; fixed in 2.15.2.1\n- json (RubyGems): affected from 2.16.0; fixed in 2.17.1.2\n- json (RubyGems): affected from 2.16.0; fixed in 2.17.1.2\n- json (RubyGems): affected from 2.18.0; fixed in 2.19.2\n- json (RubyGems): affected from 2.18.0; fixed in 2.19.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33210/ (Markdown: https://insights.sbomify.com/CVE-2026-33210/index.md)","id":"CVE-2026-33210","markdown":"https://insights.sbomify.com/CVE-2026-33210/index.md","name":"CVE-2026-33210","record":{"aliases":["CLEANSTART-2026-GD99974","CLEANSTART-2026-NM96791","DEBIAN-CVE-2026-33210","GHSA-3m6g-2423-7cp3","MINI-2j59-3p2v-p3jx","MINI-33c4-973g-j7gm","MINI-4r33-hq92-27v3","MINI-582h-hjg6-5h7q","MINI-66ff-rjm5-4hgm","MINI-68mm-w8q7-4r7f","MINI-6w4m-2g82-9c82","MINI-76qh-x377-8952","MINI-93mx-968m-xxq7","MINI-chfm-j685-7j9c","MINI-g7m3-6x7x-593x","MINI-hmhj-g895-5rr8","MINI-jcqj-r3px-mc8p","MINI-m37x-vgp8-446w","MINI-mcpw-9g8q-vc62","MINI-q5j9-pv28-f4qq","MINI-qfph-mvxp-jcwx","MINI-qvcr-96f7-w9vq","MINI-qvqg-xr83-chjm","MINI-wf53-v6c7-44qx","ROOT-APP-RUBY-CVE-2026-33210","UBUNTU-CVE-2026-33210"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby JSON library","requires_auth":"none","summary":"Attackers can cause denial of service or information disclosure via format string injection in Ruby JSON when duplicate key checking is enabled.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"json","vendor":"ruby-lang"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-134","name":"Use of Externally-Controlled Format String"}],"description":"Ruby JSON is a JSON implementation for Ruby. From version 2.14.0 to before versions 2.15.2.1, 2.17.1.2, and 2.19.2, a format string injection vulnerability can lead to denial of service attacks or information disclosure, when the allow_duplicate_key: false parsing option is used to parse user supplied documents. This issue has been patched in versions 2.15.2.1, 2.17.1.2, and 2.19.2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ruby JSON has a format string injection vulnerability","id":"CVE-2026-33210","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"other","year":"2026"},"n_packages":6,"n_references":1,"next":{"headline":"Tekton Pipelines git resolver has path traversal that allows reading arbitrary files from the resolver pod","id":"CVE-2026-33211"},"packages":[{"ecosystem":"RubyGems","fixed":["2.15.2.1"],"introduced":["2.14.0"],"last_affected":[],"package":"json","purl":null,"source":"GHSA-3m6g-2423-7cp3"},{"ecosystem":"RubyGems","fixed":["2.15.2.1"],"introduced":["2.14.0"],"last_affected":[],"package":"json","purl":"pkg:gem/json","source":"GHSA-3m6g-2423-7cp3"},{"ecosystem":"RubyGems","fixed":["2.17.1.2"],"introduced":["2.16.0"],"last_affected":[],"package":"json","purl":null,"source":"GHSA-3m6g-2423-7cp3"},{"ecosystem":"RubyGems","fixed":["2.17.1.2"],"introduced":["2.16.0"],"last_affected":[],"package":"json","purl":"pkg:gem/json","source":"GHSA-3m6g-2423-7cp3"},{"ecosystem":"RubyGems","fixed":["2.19.2"],"introduced":["2.18.0"],"last_affected":[],"package":"json","purl":null,"source":"GHSA-3m6g-2423-7cp3"},{"ecosystem":"RubyGems","fixed":["2.19.2"],"introduced":["2.18.0"],"last_affected":[],"package":"json","purl":"pkg:gem/json","source":"GHSA-3m6g-2423-7cp3"}],"prev":{"headline":"Avo has a XSS vulnerability on `return_to` param","id":"CVE-2026-33209"},"products":["json"],"published":"2026-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-21","vendors":["ruby"]},"summary":"Attackers can cause denial of service or information disclosure via format string injection in Ruby JSON when duplicate key checking is enabled.","url":"https://insights.sbomify.com/CVE-2026-33210/"}