# CVE-2026-33210: Ruby JSON has a format string injection vulnerability

> Attackers can cause denial of service or information disclosure via format string injection in Ruby JSON when duplicate key checking is enabled.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 21 Aug 2026
- **Also known as:** CLEANSTART-2026-GD99974, CLEANSTART-2026-NM96791, DEBIAN-CVE-2026-33210, GHSA-3m6g-2423-7cp3, MINI-2j59-3p2v-p3jx, MINI-33c4-973g-j7gm, MINI-4r33-hq92-27v3, MINI-582h-hjg6-5h7q, MINI-66ff-rjm5-4hgm, MINI-68mm-w8q7-4r7f, MINI-6w4m-2g82-9c82, MINI-76qh-x377-8952, MINI-93mx-968m-xxq7, MINI-chfm-j685-7j9c, MINI-g7m3-6x7x-593x, MINI-hmhj-g895-5rr8, MINI-jcqj-r3px-mc8p, MINI-m37x-vgp8-446w, MINI-mcpw-9g8q-vc62, MINI-q5j9-pv28-f4qq, MINI-qfph-mvxp-jcwx, MINI-qvcr-96f7-w9vq, MINI-qvqg-xr83-chjm, MINI-wf53-v6c7-44qx, ROOT-APP-RUBY-CVE-2026-33210, UBUNTU-CVE-2026-33210

## What is CVE-2026-33210?

CVE-2026-33210 is a high-severity vulnerability in ruby json, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ruby JSON is a JSON implementation for Ruby. From version 2.14.0 to before versions 2.15.2.1, 2.17.1.2, and 2.19.2, a format string injection vulnerability can lead to denial of service attacks or information disclosure, when the allow_duplicate_key: false parsing option is used to parse user supplied documents. This issue has been patched in versions 2.15.2.1, 2.17.1.2, and 2.19.2.

Weakness: CWE-134 (Use of Externally-Controlled Format String)

## Which versions are affected by CVE-2026-33210?

6 open source packages ship an affected version, including json. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `json` | RubyGems | From 2.14.0 | 2.15.2.1 |
| `json` | RubyGems | From 2.14.0 | 2.15.2.1 |
| `json` | RubyGems | From 2.16.0 | 2.17.1.2 |
| `json` | RubyGems | From 2.16.0 | 2.17.1.2 |
| `json` | RubyGems | From 2.18.0 | 2.19.2 |
| `json` | RubyGems | From 2.18.0 | 2.19.2 |

Products: Ruby-Lang Json.

## How do I fix CVE-2026-33210?

Upgrade json to a fixed version for your release line: 2.15.2.1, 2.17.1.2 or 2.19.2.

## Is CVE-2026-33210 being exploited?

There is no known exploitation of CVE-2026-33210 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33210 and fix it if it is affected.

What it is: CVE-2026-33210 is a high-severity vulnerability in ruby json, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33210 in the wild and no public exploit code.

Affected packages and fixed versions:
- json (RubyGems): affected from 2.14.0; fixed in 2.15.2.1
- json (RubyGems): affected from 2.14.0; fixed in 2.15.2.1
- json (RubyGems): affected from 2.16.0; fixed in 2.17.1.2
- json (RubyGems): affected from 2.16.0; fixed in 2.17.1.2
- json (RubyGems): affected from 2.18.0; fixed in 2.19.2
- json (RubyGems): affected from 2.18.0; fixed in 2.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33210/ (Markdown: https://insights.sbomify.com/CVE-2026-33210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33210
- OSV: https://osv.dev/vulnerability/CVE-2026-33210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33210/
Summaries are generated and may contain mistakes; the official description above is the record.
