CVE-2026-33216 NATS has MQTT plaintext password disclosure
Attackers can read MQTT passwords via monitoring endpoints in NATS-Server when using usercodes/passwords, requiring secured monitoring endpoints or an upgrade.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33216?
CVE-2026-33216 is a high-severity vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, for MQTT deployments using usercodes/passwords: MQTT passwords are incorrectly classified as a non-authenticating identity statement (JWT) and exposed via monitoring endpoints. Versions 2.11.14 and 2.12.6 contain a fix. As a workaround, ensure monitoring end-points are adequately secured. Best practice remains to not expose the monitoring endpoint to the Internet or other untrusted network users.
Which versions are affected by CVE-2026-33216?
9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15, 2.12.6 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.6 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.6 |
nats Bitnami | All versions | 2.11.15, 2.12.6 |
3 more packages
github.com/nats-io/nats-server Go | All versions | None |
github.com/nats-io/nats-server Go | All versions | None |
github.com/nats-io/nats-server Go | All versions | None |
Products include Linuxfoundation Nats-Server.
How do I fix CVE-2026-33216?
Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.
Is CVE-2026-33216 being exploited?
There is no known exploitation of CVE-2026-33216 in the wild and no public exploit code.
Other vulnerabilities in nats-io nats-server
- CVE-2022-28357 NATS nats-server allows directory traversal via unintended path to a management action
- CVE-2026-58253 NATS Server: Route API Auth Bypass
- CVE-2022-24450 Incorrect Authorization in NATS nats-server
- CVE-2026-58207 NATS Server: Remote crash via integer overflow in Connz pagination
- CVE-2026-58210 NATS Server: MQTT partial CONNECT packets can exhaust pre-auth memory
Sources
Also known as AZL-81636, BIT-nats-2026-33216, CLEANSTART-2026-FZ43945, DEBIAN-CVE-2026-33216, ECHO-d182-03b5-4078, GHSA-v722-jcv5-w7mc and 11 more.