# CVE-2026-33216: NATS has MQTT plaintext password disclosure

> Attackers can read MQTT passwords via monitoring endpoints in NATS-Server when using usercodes/passwords, requiring secured monitoring endpoints or an upgrade.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 9 Sep 2026
- **Also known as:** AZL-81636, BIT-nats-2026-33216, CLEANSTART-2026-FZ43945, DEBIAN-CVE-2026-33216, ECHO-d182-03b5-4078, GHSA-v722-jcv5-w7mc, GO-2026-4836, JLSEC-2026-1124, MINI-2qmh-53xv-5fvv, MINI-7fr7-8g4f-c7vv, MINI-8c45-fm3w-hfxj, MINI-9x7c-fvmm-f4m6, MINI-jwrg-j6jr-396h, MINI-p5cp-53jc-c4f8, MINI-xxx4-fj4m-cvq4, ROOT-APP-GOBINARY-CVE-2026-33216, UBUNTU-CVE-2026-33216

## What is CVE-2026-33216?

CVE-2026-33216 is a high-severity vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, for MQTT deployments using usercodes/passwords: MQTT passwords are incorrectly classified as a non-authenticating identity statement (JWT) and exposed via monitoring endpoints. Versions 2.11.14 and 2.12.6 contain a fix. As a workaround, ensure monitoring end-points are adequately secured. Best practice remains to not expose the monitoring endpoint to the Internet or other untrusted network users.

Weakness: CWE-213 (Exposure of Sensitive Information Due to Incompatible Policies), CWE-256 (Plaintext Storage of a Password)

## Which versions are affected by CVE-2026-33216?

9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `nats` | Bitnami | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2026-33216?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.

## Is CVE-2026-33216 being exploited?

There is no known exploitation of CVE-2026-33216 in the wild and no public exploit code.

## Other vulnerabilities in nats-io nats-server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)
- [CVE-2026-58210](https://insights.sbomify.com/CVE-2026-58210/): NATS Server: MQTT partial CONNECT packets can exhaust pre-auth memory (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33216 and fix it if it is affected.

What it is: CVE-2026-33216 is a high-severity vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33216 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- nats (Bitnami): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33216/ (Markdown: https://insights.sbomify.com/CVE-2026-33216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33216
- OSV: https://osv.dev/vulnerability/CVE-2026-33216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33216/
Summaries are generated and may contain mistakes; the official description above is the record.
