CVE-2026-33218 NATS has pre-auth server panic via leafnode handling
An attacker can crash the NATS server by sending a malformed message to the leafnode port before authentication, requiring leafnode support to be enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33218?
CVE-2026-33218 is a high-severity denial of service vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, a client which can connect to the leafnode port can crash the nats-server with a certain malformed message pre-authentication. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, disable leafnode support if not needed or restrict network connections to the leafnode port, if plausible without compromising the service offered.
Which versions are affected by CVE-2026-33218?
9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15, 2.12.6 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.6 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.6 |
nats Bitnami | All versions | 2.11.15, 2.12.6 |
3 more packages
github.com/nats-io/nats-server Go | All versions | None |
github.com/nats-io/nats-server Go | All versions | None |
github.com/nats-io/nats-server Go | All versions | None |
Products include Linuxfoundation Nats-Server.
How do I fix CVE-2026-33218?
Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-33218 being exploited?
There is no known exploitation of CVE-2026-33218 in the wild and no public exploit code.
Other vulnerabilities in nats-io nats-server
- CVE-2022-28357 NATS nats-server allows directory traversal via unintended path to a management action
- CVE-2026-58253 NATS Server: Route API Auth Bypass
- CVE-2022-24450 Incorrect Authorization in NATS nats-server
- CVE-2026-33216 NATS has MQTT plaintext password disclosure
- CVE-2026-58207 NATS Server: Remote crash via integer overflow in Connz pagination
Sources
Also known as BIT-nats-2026-33218, CLEANSTART-2026-IK89533, DEBIAN-CVE-2026-33218, ECHO-8ad9-3d98-b124, GHSA-vprv-35vv-q339, GO-2026-4837 and 10 more.