# CVE-2026-33218: NATS has pre-auth server panic via leafnode handling

> An attacker can crash the NATS server by sending a malformed message to the leafnode port before authentication, requiring leafnode support to be enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 9 Sep 2026
- **Also known as:** BIT-nats-2026-33218, CLEANSTART-2026-IK89533, DEBIAN-CVE-2026-33218, ECHO-8ad9-3d98-b124, GHSA-vprv-35vv-q339, GO-2026-4837, JLSEC-2026-1126, MINI-3c4c-fx2x-m9hp, MINI-3r3x-5wxm-8fxq, MINI-3xm2-mx9h-f9fh, MINI-46pg-vph2-f38r, MINI-726c-j879-4jgg, MINI-hp4j-72cm-mp94, MINI-qhh6-xm9f-557q, ROOT-APP-GOBINARY-CVE-2026-33218, UBUNTU-CVE-2026-33218

## What is CVE-2026-33218?

CVE-2026-33218 is a high-severity denial of service vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, a client which can connect to the leafnode port can crash the nats-server with a certain malformed message pre-authentication. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, disable leafnode support if not needed or restrict network connections to the leafnode port, if plausible without compromising the service offered.

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-33218?

9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `nats` | Bitnami | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2026-33218?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.

## Is CVE-2026-33218 being exploited?

There is no known exploitation of CVE-2026-33218 in the wild and no public exploit code.

## Other vulnerabilities in nats-io nats-server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33218 and fix it if it is affected.

What it is: CVE-2026-33218 is a high-severity denial of service vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33218 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- nats (Bitnami): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33218/ (Markdown: https://insights.sbomify.com/CVE-2026-33218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33218
- OSV: https://osv.dev/vulnerability/CVE-2026-33218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33218/
Summaries are generated and may contain mistakes; the official description above is the record.
