# CVE-2026-33220: Weblate: JavaScript localization CDN add-on allows arbitrary local file read outside the repository

> Attackers can read arbitrary local files outside the repository via the translation memory API if the CDN add-on is enabled.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-mqph-7h49-hqfm, PYSEC-2026-153

## What is CVE-2026-33220?

CVE-2026-33220 is a medium-severity path traversal vulnerability in WeblateOrg weblate, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Weblate is a web based localization tool. In versions prior to 5.17, the translation memory API exposed unintended endpoints, which in turn didn't perform proper access control. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can disable this feature as the CDN add-on is not enabled by default.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-33220?

3 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.17 |
| `weblate` | PyPI | All versions | 5.17 |
| `Weblate` | PyPI | All versions | 5.17 |

Products: Weblate Weblate.

## How do I fix CVE-2026-33220?

Upgrade weblate to 5.17 or later.

## Is CVE-2026-33220 being exploited?

There is no known exploitation of CVE-2026-33220 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33220 and fix it if it is affected.

What it is: CVE-2026-33220 is a medium-severity path traversal vulnerability in WeblateOrg weblate, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33220 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.17
- weblate (PyPI): affected all versions; fixed in 5.17
- Weblate (PyPI): affected all versions; fixed in 5.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33220/ (Markdown: https://insights.sbomify.com/CVE-2026-33220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33220
- OSV: https://osv.dev/vulnerability/CVE-2026-33220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33220/
Summaries are generated and may contain mistakes; the official description above is the record.
