# CVE-2026-33222: NATS JetStream has an authorization bypass through its Management API

> Users with limited JetStream restore permissions can bypass authorization to restore data into unauthorized streams, affecting NATS Server deployments.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** BIT-nats-2026-33222, CLEANSTART-2026-YB47349, DEBIAN-CVE-2026-33222, ECHO-1242-81fa-2b3a, GHSA-9983-vrx2-fg9c, GO-2026-4832, JLSEC-2026-1128, MINI-2xrw-r6m2-5vf7, MINI-46vg-jqq2-v8p3, MINI-fv9w-85w4-6g2c, MINI-hqfr-3m4h-2gr6, MINI-mq98-8vg8-f93x, MINI-r5f3-m5qp-264q, MINI-wcwr-83wx-hg7x, ROOT-APP-GOBINARY-CVE-2026-33222, UBUNTU-CVE-2026-33222

## What is CVE-2026-33222?

CVE-2026-33222 is a medium-severity authentication bypass vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, users with JetStream admin API access to restore one stream could restore to other stream names, impacting data which should have been protected against them. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, if developers have configured users to have limited JetStream restore permissions, temporarily remove those permissions.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-33222?

9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `nats` | Bitnami | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2026-33222?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.

## Is CVE-2026-33222 being exploited?

There is no known exploitation of CVE-2026-33222 in the wild and no public exploit code.

## Other vulnerabilities in nats-io nats-server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33222 and fix it if it is affected.

What it is: CVE-2026-33222 is a medium-severity authentication bypass vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33222 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- nats (Bitnami): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33222/ (Markdown: https://insights.sbomify.com/CVE-2026-33222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33222
- OSV: https://osv.dev/vulnerability/CVE-2026-33222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33222/
Summaries are generated and may contain mistakes; the official description above is the record.
