# CVE-2026-33223: NATS Server: Incomplete Stripping of Nats-Request-Info Header Allows Identity Spoofing

> Attackers with valid credentials can spoof their identity by exploiting incomplete header stripping, bypassing identity guarantees in NATS Server.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** BIT-nats-2026-33223, CLEANSTART-2026-OV69039, DEBIAN-CVE-2026-33223, ECHO-cc28-ca6d-d8db, GHSA-pwx7-fx9r-hr4h, GO-2026-4835, JLSEC-2026-1129, MINI-44gq-w37p-3fhq, MINI-g83h-jhwh-pgfh, MINI-q7hm-78r7-6rwf, MINI-vqqp-cqqx-555x, MINI-wg9f-v3f3-wxqh, MINI-wmqp-x522-m4c5, MINI-x3p2-mh2m-gxcq, ROOT-APP-GOBINARY-CVE-2026-33223, UBUNTU-CVE-2026-33223

## What is CVE-2026-33223?

CVE-2026-33223 is a medium-severity authentication bypass vulnerability in nats-io nats-server, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, the NATS message header `Nats-Request-Info:` is supposed to be a guarantee of identity by the NATS server, but the stripping of this header from inbound messages was not fully effective. An attacker with valid credentials for any regular client interface could thus spoof their identity to services which rely upon this header. Versions 2.11.15 and 2.12.6 contain a fix. No known workarounds are available.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-33223?

9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `nats` | Bitnami | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2026-33223?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.

## Is CVE-2026-33223 being exploited?

There is no known exploitation of CVE-2026-33223 in the wild and no public exploit code.

## Other vulnerabilities in nats-io nats-server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33223 and fix it if it is affected.

What it is: CVE-2026-33223 is a medium-severity authentication bypass vulnerability in nats-io nats-server, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33223 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- nats (Bitnami): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33223/ (Markdown: https://insights.sbomify.com/CVE-2026-33223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33223
- OSV: https://osv.dev/vulnerability/CVE-2026-33223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33223/
Summaries are generated and may contain mistakes; the official description above is the record.
