CVE-2026-33227 Apache ActiveMQ: Improper validation and restriction of a classpath path name
Authenticated users can traverse the classpath via crafted keys in STOMP or Web console, potentially enabling resource loading attacks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33227?
CVE-2026-33227 is a medium-severity path traversal vulnerability in Apache Activemq, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper validation and restriction of a classpath path name vulnerability in
Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ.
In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit.
This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2.
Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.
Weakness: CWE-22
Which versions are affected by CVE-2026-33227?
17 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-all Maven | All versions | 5.19.3 |
org.apache.activemq:activemq-all Maven | All versions | 5.19.3 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.2 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.2 |
activemq Bitnami | All versions | 5.19.3, 6.2.2 |
org.apache.activemq:activemq-broker Maven | All versions | 5.19.3 |
11 more packages
org.apache.activemq:activemq-broker Maven | All versions | 5.19.3 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.2 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.2 |
org.apache.activemq:activemq-client Maven | All versions | 5.19.3 |
org.apache.activemq:activemq-client Maven | All versions | 5.19.3 |
org.apache.activemq:activemq-client Maven | From 6.0.0 | 6.2.2 |
org.apache.activemq:activemq-client Maven | From 6.0.0 | 6.2.2 |
org.apache.activemq:activemq-web Maven | All versions | 5.19.3 |
org.apache.activemq:activemq-web Maven | All versions | 5.19.3 |
org.apache.activemq:activemq-web Maven | From 6.0.0 | 6.2.2 |
org.apache.activemq:activemq-web Maven | From 6.0.0 | 6.2.2 |
Products include Apache Activemq, Apache Activemq Broker, Apache Activemq Web.
How do I fix CVE-2026-33227?
Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.3 or 6.2.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-33227 being exploited?
There is no known exploitation of CVE-2026-33227 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-33227, DEBIAN-CVE-2026-33227, GHSA-h2h4-5m64-m273, MINI-9xg2-hrr3-5rq4, MINI-qg4w-8j9r-2m57, MINI-qxx3-8vj9-gq6v and 5 more.