# CVE-2026-33227: Apache ActiveMQ: Improper validation and restriction of a classpath path name

> Authenticated users can traverse the classpath via crafted keys in STOMP or Web console, potentially enabling resource loading attacks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** BIT-activemq-2026-33227, DEBIAN-CVE-2026-33227, GHSA-h2h4-5m64-m273, MINI-9xg2-hrr3-5rq4, MINI-qg4w-8j9r-2m57, MINI-qxx3-8vj9-gq6v, MINI-v6f5-3v3r-ffpp, MINI-w7v5-gjjc-3q3m, MINI-wpf2-w3g2-6h98, ROOT-APP-MAVEN-CVE-2026-33227, UBUNTU-CVE-2026-33227

## What is CVE-2026-33227?

CVE-2026-33227 is a medium-severity path traversal vulnerability in Apache Activemq, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper validation and restriction of a classpath path name vulnerability in 

 Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ.

In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit.

This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2.

Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-33227?

17 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.3 |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.3 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.2 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.2 |
| `activemq` | Bitnami | All versions | 5.19.3, 6.2.2 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.3 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.3 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.2 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.2 |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.19.3 |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.19.3 |
| `org.apache.activemq:activemq-client` | Maven | From 6.0.0 | 6.2.2 |
| `org.apache.activemq:activemq-client` | Maven | From 6.0.0 | 6.2.2 |
| `org.apache.activemq:activemq-web` | Maven | All versions | 5.19.3 |
| `org.apache.activemq:activemq-web` | Maven | All versions | 5.19.3 |
| `org.apache.activemq:activemq-web` | Maven | From 6.0.0 | 6.2.2 |
| `org.apache.activemq:activemq-web` | Maven | From 6.0.0 | 6.2.2 |

Products: Apache Activemq, Apache Activemq Broker, Apache Activemq Web.

## How do I fix CVE-2026-33227?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.3 or 6.2.2.

## Is CVE-2026-33227 being exploited?

There is no known exploitation of CVE-2026-33227 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33227 and fix it if it is affected.

What it is: CVE-2026-33227 is a medium-severity path traversal vulnerability in Apache Activemq, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33227 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.3
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.3
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.2
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.2
- activemq (Bitnami): affected all versions; fixed in 5.19.3, 6.2.2
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.3
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.3
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.2
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.2
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.19.3
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.19.3
- org.apache.activemq:activemq-client (Maven): affected from 6.0.0; fixed in 6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33227/ (Markdown: https://insights.sbomify.com/CVE-2026-33227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33227
- OSV: https://osv.dev/vulnerability/CVE-2026-33227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33227/
Summaries are generated and may contain mistakes; the official description above is the record.
