CVE-2026-33229 XWiki Platform affected by remote code execution with script right through unprotected Velocity scripting API
Users with script rights can bypass Velocity sandboxing to execute arbitrary code, compromising the entire XWiki instance.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33229?
CVE-2026-33229 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 8 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.4.8 and 17.10.1, an improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. This vulnerability is fixed in 17.4.8 and 17.10.1.
Weakness: CWE-862
Which versions are affected by CVE-2026-33229?
8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-legacy-oldcore and org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 17.0.0-rc-1 | 17.4.8 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 17.0.0-rc-1 | 17.4.8 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 17.5.0-rc-1 | 17.10.1 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 17.5.0-rc-1 | 17.10.1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 17.0.0-rc-1 | 17.4.8 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 17.0.0-rc-1 | 17.4.8 |
2 more packages
org.xwiki.platform:xwiki-platform-oldcore Maven | From 17.5.0-rc-1 | 17.10.1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 17.5.0-rc-1 | 17.10.1 |
Products include Xwiki Xwiki.
How do I fix CVE-2026-33229?
Upgrade org.xwiki.platform:xwiki-platform-legacy-oldcore to a fixed version for your release line: 17.4.8 or 17.10.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-33229 being exploited?
There is no known exploitation of CVE-2026-33229 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-h259-74h5-4rh9.