# CVE-2026-33230: nltk Vulnerable to Cross-site Scripting

> Attackers can execute arbitrary JavaScript in the browser of users running the local NLTK WordNet Browser server via a crafted URL.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33230, ECHO-71be-89bb-7761, GHSA-gfwx-w7gr-fvh7, MGASA-2026-0082, MINI-2m5f-4f52-x27m, PYSEC-2026-2235, ROOT-APP-PYPI-CVE-2026-33230, UBUNTU-CVE-2026-33230, USN-8302-1, openSUSE-SU-2026:10461-1

## What is CVE-2026-33230?

CVE-2026-33230 is a medium-severity cross-site scripting vulnerability in nltk, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NLTK (Natural Language Toolkit) is a suite of open source Python modules, data sets, and tutorials supporting research and development in Natural Language Processing. In versions 3.9.3 and prior, `nltk.app.wordnet_app` contains a reflected cross-site scripting issue in the `lookup_...` route. A crafted `lookup_<payload>` URL can inject arbitrary HTML/JavaScript into the response page because attacker-controlled `word` data is reflected into HTML without escaping. This impacts users running the local WordNet Browser server and can lead to script execution in the browser origin of that application. Commit 1c3f799607eeb088cab2491dcf806ae83c29ad8f fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-33230?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.9.4 |
| `nltk` | PyPI | All versions | 3.9.4 |
| `nltk` | PyPI | All versions | 3.9.4 |
| `python-nltk` | openSUSE:Tumbleweed | All versions | 3.9.4-1.1 |

Products: Nltk Nltk.

## How do I fix CVE-2026-33230?

Upgrade nltk to 3.9.4 or later.

## Is CVE-2026-33230 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33230 exists.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33230 and fix it if it is affected.

What it is: CVE-2026-33230 is a medium-severity cross-site scripting vulnerability in nltk, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33230 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.9.4
- nltk (PyPI): affected all versions; fixed in 3.9.4
- nltk (PyPI): affected all versions; fixed in 3.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33230/ (Markdown: https://insights.sbomify.com/CVE-2026-33230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33230
- OSV: https://osv.dev/vulnerability/CVE-2026-33230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33230/
Summaries are generated and may contain mistakes; the official description above is the record.
