# CVE-2026-33233: AutoGPT Platform: Remote Code Execution via Unsafe Pickle Deserialization of Redis Cache Entries

> Attackers can execute arbitrary code by poisoning Redis cache entries due to unsafe pickle deserialization in the AutoGPT backend.

- **Severity:** High 7.6 (`CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 May 2026
- **Updated:** 19 May 2026
- **Also known as:** GHSA-rfg2-37xq-w4m9

## What is CVE-2026-33233?

CVE-2026-33233 is a high-severity unsafe deserialization vulnerability in Significant-Gravitas AutoGPT, published on 19 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. In versions 0.6.34 through 0.6.51, the backend deserializes Redis cache bytes using pickle.loads without integrity/authenticity checks. The write path serializes values with pickle.dumps(...) into Redis and the read path blindly invokes pickle.loads(...) on bytes with no HMAC/signature or strict schema validation gating deserialization. If an attacker can poison a shared-cache key in Redis, arbitrary command execution is possible in the backend container context, affecting confidentiality, integrity, and availability. This issue has been fixed in version 0.6.52.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-502 (Deserialization of Untrusted Data), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-33233?


## How do I fix CVE-2026-33233?

No fix has been published for CVE-2026-33233 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33233 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33233 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33233 and fix it if it is affected.

What it is: CVE-2026-33233 is a high-severity unsafe deserialization vulnerability in Significant-Gravitas AutoGPT, published on 19 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33233 exists.

Affected product: Significant-Gravitas AutoGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33233/ (Markdown: https://insights.sbomify.com/CVE-2026-33233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33233
- OSV: https://osv.dev/vulnerability/CVE-2026-33233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33233/
Summaries are generated and may contain mistakes; the official description above is the record.
