# CVE-2026-33235: AutoGPT: Denial of Service (DoS) via Resource Exhaustion in text templating features

> Attackers can cause service outages in AutoGPT by submitting computationally expensive Jinja2 expressions that exhaust server resources.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-ppw9-h7rv-gwq9

## What is CVE-2026-33235?

CVE-2026-33235 is a high-severity denial of service vulnerability in Significant-Gravitas AutoGPT, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. In versions prior to 0.6.52, the Fill Text Template block is vulnerable to a Denial of Service (DoS) attack. While the backend implements a SandboxedEnvironment to prevent unauthorized attribute access (e.g., blocking __class__), it fails to limit the computational complexity or execution time of the expressions. An attacker can input computationally expensive Python/Jinja2 expressions that consume the server's CPU and memory, leading to a complete system hang or crash. In multi-tenant or self-hosted environments, this results in a complete service outage and "noisy neighbor" effects that require manual administrative intervention to recover. This issue has been fixed in version 0.6.52.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-33235?


## How do I fix CVE-2026-33235?

No fix has been published for CVE-2026-33235 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33235 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33235 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33235 and fix it if it is affected.

What it is: CVE-2026-33235 is a high-severity denial of service vulnerability in Significant-Gravitas AutoGPT, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33235 exists.

Affected product: Significant-Gravitas AutoGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33235/ (Markdown: https://insights.sbomify.com/CVE-2026-33235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33235
- OSV: https://osv.dev/vulnerability/CVE-2026-33235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33235/
Summaries are generated and may contain mistakes; the official description above is the record.
